Download

[PROBLEM] Low poly / compiling shaders

Hi guys,

I’ve starting my first project 4month ago…
First make landscape, foliage, rock…etc…use epic free assets…all very beautiful…
After i’m starting make a big house in details working 1 month on this…just finish

But now, looking my landscape, foliage, mesh…all became lowpoly !!

153ea743d25548c9bea8a15a6bdee68c3863f8f5.jpeg

What’s happen ?

My parameters looks good :

c2d59c8d8baefbb05586926ddb1e45f7af6cda79.jpeg

Just have upgrade my engine 4.12.5, no pluggins…

  • Load Epic project (particle project) => no problem.

  • Start new project => no problem.

  • Add new SM_Rock (epic mesh) or existing foliage and my project => low poly !!

Any ideas ??

It’s look like there is no compiling shader on my landscape / rock / foliage…

Please help me…5 months of hard work…

Thanks guys.

No ideas ?

I have the same problem with my grass, but not any of the rest of it. :confused:

I’ve clean my DerivedDatacache…no result…

I’ve started new project and copy/paste my meshes…
First it’s good…but one moment after…all became lowpoly…really don’t know what’s happen…

Not really photorealistic -_-

Tried this?

https://answers.unrealengine.com/questions/341703/how-to-make-the-texture-streaming-memory-pool-larg.html

I’ll try that and let you know, but it would also be nice to know what initially caused it and how to fix that.

OMG !

Monsterlutz, you save me !! It’s working !

Perhaps my level is too big…

Solution :

1/ Go to C:\Program Files (x86)\Epic Games\4.12\Engine\Config and open ConsoleVariables.ini

2/ Add this : r.Streaming.PoolSize=4000 and save…

691f67623edf63e80d006a52f20111150c2fdca4.jpeg

3/ Open project and enjoy.

Thanks you a lot !!

I finally got around to it. Didn’t work for me. What worked was placing a static mesh of the grass in the scene and walking straight up to it so that its streaming priority would get a boost. Obviously this isn’t an ideal permanent solution!