Download

PROBLEM: How to set ray traced distance field soft shadows?

i followed this manual in UE4 documentation but there is pretty little information.
https://docs.unrealengine.com/latest/INT/Engine/Rendering/LightingAndShadows/RayTracedDistanceFieldShadowing/index.html

ive enabled the Generate Mesh Distance Fields option in the project files rendering section, ive set the Distance Field Resolution on the floor on max, ive set the the point light on movable and ive enabled the Use RayTraced DistanceField Shadows options. i dont know if i missed something but it looks like theres nothing more in the documentation.

my results are really awful:

3a6efb2f959c6aae2e746e55f0c0956c706d8782.jpeg

i couldnt even make it work with the directional light. i would really appreciate better documentation because its the only source we have.

Set the CSM distance to 0 and the new shadows show up. I didnt test if the CSMs are kicking in at some distance or not.

Looks like it’s working in your picture.

If you want to increase the quality of the shadow from the nearby object you need to increase it’s distance field resolution, not the floor. This is different than lightmaps, the distance fields are used to cast shadows so it’s the shadow casters resolution that matters and not the receiver.

The floor mesh can probably use an even lower resolution scale than 1.0.

It’s much easier to understand what is going on if you enable the Mesh Distance Field visualization as you can clearly see which meshes needs a higher resolution.

Applies to shadow casting also: https://docs.unrealengine.com/latest/INT/Engine/Rendering/LightingAndShadows/DistanceFieldAmbientOcclusion/index.html#troubleshootingandquality

+1 to what Parkar said, use the Visualize -> Mesh Distance Fields mode to view distance fields, raise Distance Field Resolution Scale on meshes with too low of resolution that are causing problems.

I do not want to create a new thread, but why is this happening. Its so frustrating. Did you made purposely made features more difficult to use then need be…lol
Greyed.JPG

Did you restart the editor after enabling Generate Mesh Distance Fields? And is that light stationary or movable? Because it doesnt work with Static lights.

Oh my god, I am looking silly, I missed the “The editor must be restarted after changing the value of this setting.” text, never mind its highlighted in yellow box in the documentation, & also editor.

This is totally my fault. LOL