Problem Creating a c++ Project

I’m trying to make a blank c++ project when I get the message “ERROR: No 32-bit compiler toolchain found in C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\cl.exe” I have spent a day looking for answers and the only one I found was This one which did not help me as I am using visual studio 2017 installed and have all the c++ components installed. Do I need vs 2015? or am I doing something else wrong? Any help would be greatly appreciated.

Hi Legend965,

I believe you need to specify -2017 when generating your project files through GenerateProjectFiles.bat to use Visual Studio 2017. See VCEnvironment.cs and VCProjectFileGenerator.cs for more information.

Hope that helps. Cheers,

Hi project.geist,

Sorry but I’m a complete noobie at all of this. Could you go into a little more detail?

Thanks in advance

From what I can gather, Visual Studio 2017 is not supported at this time. I would sincerely suggest downloading Visual Studio 2015 for the time being.

Sorry for the late reply. I meant that you run the bat file through the command line (simplest way) with -2017 like GenerateProjectFiles.bat -2017.

Thanks, I’ll have it a shot

Tried this, also tried uninstalling 2017 and getting 2015… still getting the same message.

Tried this, I’m still getting the same message about the 32-bit compiler.