Problem: can't get bumping or tessellation to work with my materials

Hi! I recently started using UE4 (4.8) and wanted to try to create a texture with bump mapping. Using blender, I got a normals map, a displacement map and the oclusions, which I would use a difuse map.

I created a new material and started to apply them. I had no problems with the oclusion, and the normals looked great. The same can’t be said about the displacment.

I tried to do what I found online: I used one of the channels from the displacement map as the height for a BumpOffset node. Then I connected it to the UVs of the other maps. Nothing happened, there is no visible depth, just a really strange distortion. Changing te paramters of the BumpOffset node to really high values, the distortion is really strong, but it’s in no way depth, it’s some kind of strange refraction. I have attached a picture with the material blueprint where you can clearly see it near the handle.

I tried multiplying it in case it was too weak. The result was really strange, again with a visible distortion which seems to actually have depth, but it distorts the texture. Here you have a little video using a x6 multiplier:

After this I tried to use tesellation instead. I activated it, increased the maximum displacement and connected the map to World Displacement. There was no displacement. I also tried connecting it to other parameters just in case.

At this point I though that maybe there was something wrong with my displacement map. I tried using one included in the example projects and the results were the same.

Do you know what could be wrong? Any settings I should change? Already included assets work fine, by the way.

Bump ( ;_; ) because I really need some fancy textures.

add in your material bumpoffset constant in coordinate , and heighratioinput , changue constant to constant parameter, and create material instance. changue values … example 0.001 for 0.002 and others. and previsualize in viewport no in mode material editor. understand? :smiley:

Thanks for the tip! I have tried with several combinations, but still no luck (it’s a really psychedelic experience, though).

  1. The Plane you have the material applied to needs a few vertices (more than 4) to begin with.
  2. Turn Tesselation on in the settings (PM Triangles)
  3. Hook up the displacement texture to world displacement (maybe play around with a multiplier here)
  4. Hook up a scalar value of maybe 1 or 2 to tessalation multiplier

Dont see no reason why it shouldn´t work.

The reason, I believe, that you get some psychadelic effects is that your displacement map goes form white to a completely black background with no transition area.

I tried changing the grey levels so that there is no black and blurring the picture, but the same thing happens:

There I show extreme values, but low values also cause strange results. Changing some connections (coordinates mainly) just causes different distortions.

Just in case: for tessellation, this is pretty much the basic setup for it.
Mainly what’s inside the displacement and tessellation comment boxes, and of course, having it turned on.

I don’t know what exactly you were doing but replacing the texture with what I need does the job I need it for.

As for parallax occlusion, you could try what RyanB cooked up here: POM material - Rendering - Unreal Engine Forums
Post 203 has the entire material function, just copy it and paste it into an empty function.

Also, probably should have asked first, do you want it to stick into the wall, or jut out?

Thanks! using the same setup tesselation works perfectly. I will try the part about parallax later.
I want it to jut out.

For jutting out, I don’t think parallax occlusion is gonna do what you want it to. It works better for digging into things, like cracks, or the mortar between bricks.
And just in case, don’t forget that tessellation adds to the poly count, parallax does some mathematical wizardry with UVs, so it appears to have depth.

Your bump offset looks correct actually. That artifact you see is expected since bump offset does not solve the ray intersection, it assumes all the offset pixels are on the same Z plane. It really only works well for very subtle cases where all the shapes are similar forms so you don’t notice it. With a single defined shape like a statue it will always look messed up.

If you want correct parallax for a shape like that you should look at a thread called “POM Materials” here.

bogieman is correct, jutting out is not usually done but you can do it by offsetting your geometry along the vertex normal before “pushing in” using parallax.