Prevent Camera Moving On Pawn Posession?

Hi, I can’t seem to figure out how to prevent the camera from jumping from pawn to pawn on possession. I"m doing a top down game that allows you to control a pawn by clicking on it. I tried disabling “Auto Manage Active Camera Target” but it doesn’t seem to work. I found this post on the AnswerHub, but a solution was never posted. Anybody know if this is achievable with blueprints without doing something crazy like moving all my pawn’s cameras to the same location?

I’ve only found one thing that works so far. If “Auto Manage Active Camera Target” is disabled in the controller and I then use a Set View Target node to set set the controller’s view target to a camera in the level, the view will stay locked to the camera even after possessing a new pawn. This is more of a workaround than a solution though because it means that my view is permanently locked to an actor other than the something the player controller owns. Guess it’ll work for now though.