Prerequisites error E-1223 - could not install

Same issue, I have resumed and re-installed multiple times, also copies someone else’s files and tried verifying that, but keep getting the same error.

Would love to know a fix!

Hi!!!
I´m trying to install Unreal Engine 4.10 , the first one on this machine:
(2.8GHz, W7- 64 bits, 4GB ram, 1GB video card.
The download is ok, but when the installation process finishes “prerequisites”, one error message appears and say:

Install Failed
The necessary prerequisites have failed to install. Error code R-1638


Reading questions and its answers at Answerhub, I already had installed:
Visual Studio Interprise 2015 with Update 1
Visual Studio Professional 2015 with Update 1
Microsoft Visual C++ Redistributable (X86) 2012, 2013 and 2015
Microsoft Visual C++ Redistributable (X64) 2012, 2013 and 2015

Windows 7 is up to date.

How can I do??? Thanks!!! :wink:

I really don´t know if work with only 4GB Ram is the reason of this problem. And more, the error name alternates: sometimes E-1223 and sometimes R-1638…
Would love to know how to fix too!!

Same problem. Not RAm - 16gb here, so definitely not an issue. Getting the error about not being able to install prerequistes. I am using VC2014 but do have VC++ 2015 redistributable components (I just saw them in control panel / programs and features). Tried both on windows 8 and windows 10 - no luck

Bingo ! That was it. Just uninstalled VC2015 redistributables (I did both 64 and 86) from the control panel and rerun 4.10 installer. It worked !

Alright so I have the same problem and do not have the time to test this fix right now, but as my error alternates between 1223 and 1638 - and the issues seem the same, maybe this helps:

Tardygrade!!! Thank You!!! Your procedures solved my installation problem, and now the Unreal Engine 4.10 works fine!!!
So, for our cases the problems was solved!!!
Greetings!!

Hi!!!
Just follow the Tardygrade´s procedure, uninstalling Microsoft Visual C++ 2015 (X64) and (X86). After this, run the Epic Games Launcher again.

Note: when the shortcut was created in my desktop, it was connectet to EpicGamesLauncher Win 32… so, up une level for directories and choose the Win64 version!!!

search for Epic Games / Launcher / Portal / Binaries / Win32 or V64…

Thanks! I’m working on trying out the fix right now, reinstalling takes a bit of time :stuck_out_tongue: but I hope it works!

Tried all of the above listed solutions but continued to get the Prerequisite error. I had the 2015 C++ redistributables installed, although I did not have VS 2015 or any previous version on my Windows 8.1 Install.

  • I deleted them and then tried to
    install UE4 from the Epics Game
    Launcher and got the same error

  • I installed the 2015 C++
    redistributables from microsoft site
    and still got the same error

  • I installed the Visual Studio Community
    Free edition
    , then relaucned Epic
    Games Launcher and UE4 installed
    without any errors.

This definitely worked for me also thank you tardygrade and JBN2171 for logging it on here - I did the same thing "… uninstalled VC2015 redistributables (I did both 64 and 86) from the control panel and rerun 4.10 installer. "

I also had to disable my Bitdefender Total Internet Security through the installation process while installing UNREAL ENGINE 4 v10

Cheers for updating it on here, I was pulling my hair out trying to fix it!

I had the same problem on an i7 @3.4GHz, with Windows 10 64bits with 16GB RAM and 1GB video card. Without doing any of the above solutions (I didn’t deinstall or reinstall anything, I was still reading your kinf answers), on its 5th attempt UE 4.10.1 installed itself succesfully.

Having the same problem on my laptop, which doesn’t have visual studio installed on it in the first place. Have gone through all the recommended solutions, and have tried repeatedly downloading 10.1 with no joy :frowning:

Hi Russ,

Are you getting the same error message? Could you please provide a screenshot of the error?

For me, simply deleting the redistributables (VS 2015 x86 and x64) was not enough. I had to also download the lastest versions of them from the Microsoft site and then install them. It was only after the previous redistributables were deleted and new copies were installed that it worked.

I also added exception folders to my anti-virus for the Unreal Engine folder just to be safe. Anti-virus software has interfered with me being able to install and use Visual Studio 2015. It seems other people are having similar problems with anti-viruses messing up VS 2015 installs, not just within UE4 but in other contexts also.

Also, maybe the redistributables that came bundled with UE4 or VS2015 were bad or had install errors?

Worked perfectly guys! :slight_smile: thanks a bunch.

Hi, just wanted to say that I ran in to this issue today. After trying all the suggested solutions with no luck, I tried doing a right-click Run as Administrator on the shortcut while executing the Launcher, and the setup to 4.10.2 completed fine. It was just a permissions issue but was throwing the prereq error.

Run as Administrator, it worked to me! Thanks!

Hello
I had the same issue but solved it like this:
right click on app>properties> security tab>Edit>choose user name on the list>give full control

You may also have to remove the UE4 prerequisites using the control panel as well.