PostProcessing BUG? Colored noise filter appears

Hi! Here’s a problem that I’ve been dealing with for a long time, even in previous UE versions.

I’ve set up some different color gradings for my maps in PostProcessVolume. But when I open one of these levels (in editor as well as in play mode) a filter with red noise covers the darker parts of the map (see pictures below) However, when I expand the ‘Scene Color’ tab, the noise filter disappears. Note: I do NOT change any options, I only expand the tab.

The red noise returns when opening another map, and sometimes it appears again even after expanding the ‘Scene Color’ tab.

My guess is that this is a UE bug, but is there a way for me to fix this issue?
Thankful for replies! :slight_smile:


Red noise filter:

When expanding ‘Scene Color’ tab:

Hey Accel,

This is quite the interesting issue, and seems like it should be something fairly easy to reproduce. Would you happen to have some simple steps so I can reproduce this in a blank template project like the Third Person Template using the Starter Content?

Could you also provide me with your ‘dxdiag’ so I can take a look at your systems specifications?

Do you think it could be a driver issue? Make sure you graphics drivers are up to date and see if that has an affect on your issue. Let me know if you have any further questions or need additional assistance.


It’s definately not a driver issue. I’ve tried with ceveral different computers with different graphic cards, yet get the same problem.

However, we solved the problem temporarely by modify the PostProcess settings in the level blueprint. First, set the Color Gradient Intensity to 0, then immediately afterwards set it to 1. Then the red noise dissapears in game mode, yet is still there in the editor.

Edit: The issue is not solved - see my answer below.

Hi again! Time to open this topic again, since it hasn’t been solved.

I’ve reached the conclusion that the bug is located in the ‘Color Grading’ property in PostprocessVolume. When enable, the “red noise” is likely to appear when opening level/starting game (note: the red noise doesn’t always appears, but quite frequentely)

If you change the Color Grading Intensity settings in level blueprint as I described in my answer above, the red noise disappears BUT so does the color grading. And if you try to enable color grading in level blueprint the red noise appears again… Therefore, currently, you have to choose between either 1) disable color grading and get no red noise, or 2) enable color grading and get red noise.

Obviously, I want to enable color grading without getting red noise. Would very much appreciate if someone could fix this or help me come up with a work-around soloution.

Thank you

Hey Andrew,

I get the issue when I enable Color Grading in PostProcess and adding a LUT texture. (look at my answer below)

And here’s my dxdiag: