Download

Post Processing Help for a Beginner

Hey everyone,

I am a student, and currently have one year to complete a game with my group of other students. We chose to use Unreal Engine 4, as opposed to the Unreal Engine 3 that our college already has access to. Our college does not teach Unreal 4, so we are attempting to learn it by ourselves. I have started going through the basic tutorials on the official Unreal youtube channel, and am currently on the introduction to level creation.

Everything is running smoothly, and the level creation is simple and easy. However, watching the videos, I noticed a distinct different between the room he was creating and mine - the lighting effects. His level contains a lens flare, and reflections in the materials, among other things. I would assume his level contains these by default, as the tutorial doesn’t explain how to implement them.

My room seems to have been created without the Global Postprocess actor, and I have no idea how to add that actor to the level. I can’t seem to find a tutorial for it anywhere, and I can’t seem to figure it out on my own in the engine.

Could anyone help me out? I would appreciate it very much.
Apologies if I have posted this thread in the wrong section, I will gladly recreate it in another if so.

Thank you. :slight_smile:

All you need to do is create a Post Process volume, then select the volume, and scroll down through the properties and check the Unbound box which will mean that the volume will affect the entire level instead of just the area that the volume covers. Then you can go through the properties of the volume to change settings.

A note about lens flares though–in UDK you would place a lens flare actor where you want a lens flare, UE4 doesn’t have that, it’s now a post process that gets applied to things that are bright enough, just like things would in the real world.

Thank you very much!
I located the Post Process volume and placed it in the level, and checked the Unbound box. Then, I enabled the lens flare and the reflections and hit “build”, but nothing has changed.

If there’s nothing bright enough then there’s not going to be a lens flare

Boost your lights up in your scene or change the lens flare threshold.

Thank you for all the responses.
I tried all of these solutions, but my level still seems to me missing some of the core features. For starters, I’m only getting reflections of the light sources themselves, and not reflections of actual objects (in my reflective surfaces, I can only see the point light being reflected).
For example, in this video, his reflective surfaces, such as the marble, show a reflection of the objects above them, like the doorway. I created my level with the same steps, using the same objects and materials, but I do not get these effects.
Could it be that I’m running on a decreased graphical setting? How would I go about changing that?
Upon creating the post process volume and making it global, I checked each of the features I wanted to try adding in, and none of them showed up. I experimented and increased and decreased the values in these effects, and tried boosting the lights in my scene, but nothing has made any of the post process effects show up.

It could be possibly due to your graphical setting, that feature is Screen Space Reflections which can take up a pretty good amount of processing power, if you turned down the graphics then it might have turned that off.

That could definitely be it. How can I change those settings? I can’t seem to find where to do that.

EDIT:
I have continued following the tutorials, ignoring the difference in quality. However, I have reached the point where he is adjusting the light source, and my light source behaves completely differently. For starters, I have to rebuild the lighting entirely to see its effects, I do not get a “preview” mode. In addition, my shadows are behaving very strangely. Here is a picture for reference: UnrealShadows.jpg
The light source is arranged so that the light shines in through the open wall, but here you can see that one of the pillars does not cast a shadow, and that the shadows themselves are shaped very strangely. At first I thought I had angled it incorrectly, but in the top portion of the screen you can see that the light from the sky light is coming through correctly.

In this picture, you can also see the difference in quality. I do not get reflections, or post-processing effects.

At the top click the Settings button, and then go to Engine Scalability and you can control the post processing quality there.

Thank you very much! It seems there was a much simpler solution than I thought, and now I feel silly. It looks like it automatically set itself to run at the lowest settings, and I had no idea how to find and change them. But this looks like it worked. Thanks again!
Now I get to actually experiment with my post processing.

As far as the shadows go, the objects that are receiving the shadows have their lightmap settings set too low, that’s why they look blobby.