Post Processing doesn't work in splitscreen

Using 4.6.1

I have a post process volume in my map which works fine in single player as shown below:

However, when I play in split screen multiplayer a number of post process effects are missing such as bloom, as seen below:

This problem persists in a packaged game, as well as playing in the editor. Is this expected or a bug, or is there anything I can change to fix this?

I just tried this in 4.7 R4 in a template project and the problem exists there too. Lens flares and bloom don’t work in split-screen.

Hi Mosel3y.

Thank you for reporting this. I’ve been able to successfully reproduce this and have submitted a report (UE-7627) for this issue.

I’ll update here once a fix has been submitted and verified. Unfortunately, there is no timeline for when this would be completed.

Thank you!


I am having this same problem.

This issue is currently backlogged and has not made any progress yet. Once the resolution has been submitted and verified I’ll update the post below.

Any updates on this issue? We are hoping to release our game beta in the next week or two and would really like the post processing effects to be working, especially since our game is splitscreen only. Thanks!

No significant update on the progress of this one at the moment.

This actually isn’t a “bug”, but done by design. The reason is because the the height is not a power of two and then having to be split between two screens.

This is why only some of the post processes are disabled.

From other notes, this is something that the developers want to address, but right now it is backlogged due to other priorities.

Thanks for the reply Tim, the only way I can think about actually solving this until an actual solution comes out is to make your own splitscreen with view captures. They work with post procesing no problem, but it’s still an additional step.

Hi Tim,

is it possible to point us in which files the deactivation of the post process effects happens? I would like to investigate this matter and need an anchor point.

Unfortunately, I’m not familiar with that part of code and where it’s being set or controlled. Probably something within one of the PostProcess usf file, but I am not certain.

Can we get an update on this one please?

This ticket was closed out as an intentional design choice, but did re-enable it for split-screen. I’ve not re-tested this and this is only taken from the notes in JIRA.

"There is an artifact on the split separations when the height is not a power of two (Assuming we are splitting horizontally). This artifact happens because of the power of two down sampling of the target that contains the 2 screens.

Motion blur and temporal AA has also been disabled on split screen surely for similar reasons."

Because of this you will get a bloom artifact on the top and bottom of the view.

Another comment on the ticket suggested this:

“It should be much better but I know it’s not perfect yet - especially with very extreme bloom. There is an optimization that can be controlled by r.FastBlurThreshold - that might help (large number like 1000 to disable the optimization).”

I’ve heard that a solution to this problem is downloading a developer version of UE4 that allows you to use Visual Studio to change some of the engine parameters. Doing this though will create a new engine version, and I’m worried about losing my project progress by trying to convert the project over to a different engine version. Has anyone found an easier way to solve this?

I wound up just downloading the engine source code from Git, changing the enable bloom from 0 to 1 in the ShowFlags.cpp file, and then compiling the entire engine. That fixed it for me. Took all day to compile the engine though, and then half the day to build the project for the first time.

I am wondering if I can apply the post processing to the individual character cameras, anyone got an opinion on this?

I think you better post that as a new question, as it is different enough from the original one, and people coming here to help will not notice your question if it is just a comment on a different question.