Post Processing blendables not working in 4.9

I believe there may be some kind of bug in 4.9 when it comes to post processing blendables.

I had been using the process shown in the video below to show an object that was highlighted

This is an example in 4.8

Since I upgraded to 4.9 I get this box outlined around the whole screen like so, with no desired outline

I thought this may have been something to do with the material no longer being compatable so I re-downloaded the Unreal example content and tried to find the M_Highlight material, which no longer seems to exist.

I loaded up the post processing map and went to the post processing box that contained blendables and this is the result I got. Same in the examples.

Is this is a bug, is there another way around this?

I need this process for my work. any help would be greatly appreciated.

Your post process volume isnt set to unbound and affecting it maybe?

It looks like its working, just you made a mistake somewhere.

You need to change the SceneTexture node from SceneColor to PostProcessInput0.

I have changed nothing since upgrading it to 4.9? And the last picture is of their own example in the post processing map in their examples.

Dont forget 4.9 got a major blendables / PP overhaul and just like c++ API stuff becomes depreciated, sometime blueprint and editor stuff needs to be changed with a new version.

So your desired result is the brown border around the screen?

What jacky is sayig is to go into the material editor for the materrial youir using and replace SceneTexture nodes with PostProcessInput nodes.

A pic of your setup and what your trying to acheive would help if that doesnt fix it, it sounded like you wanted to highlight meshes that are select/have the cursor over them?

Don’t forget to accept an answer that best clears your question up or answers it so when the community finds your question in the future via search/google they know exactly what you did to fix it/get it going.

Thanks for your reply. Yes the effect in the first photo is what I am trying to achieve, so I click on a mesh and it would have a highlighted border around the static mesh. This no longer happens

Thank you, I had the same problem but this fixed it :slight_smile:

Normally the frame that your seeing around the screen means that there was an issue compiling the post-process.
Open the postprocess with the material editor to see what the problem is.
My guess is that the custom depth node needs correcting since there were some changes to support custom stencils.

Thankyou, took me a little while to find where it was but this fixed it. Thankyou!