Post Process Texture Sample 4.11

Did anything change in 4.11 in terms of how post process materials handle sampling textures?

A post process I used earlier (4.10) with some sampled dynamic textures and in 4.11 they’re still emitting (tested on a billboard and mesh with regular material and they show up) but in the post process the material doesn’t show up. Any idea what could’ve changed?

I’ve updated the post and attached an example project where you can reproduce the problem.

Unzip the project and launch it. Press V to change the vector parameter on the post process (works), press T to try to change the texture parameter of the post process material (nothing happens).

The parameter passing is done in the pawn, and the post process material applied to the pawn camera is the only material in the project.

Let me know if you can spot why this functionality changed in 4.11!

Repro Project

I also hit this bug. I poked around a diff between 4.10.4 and 4.11 preview 7, but it looks like a lot of changes have happened around here and not being familiar with the code I don’t see any probable causes.

I’m gonna hop back to 4.10.4 since this is a show stopper for me. Hope it gets fixed soon!

“UE-25097 TextureSampleParameter2D ignored in PostProcessMaterial”, sounds like the problem here. According to below link it was fixed in Preview 3, but looking through commit history I don’t see it mentioned.

Well I found a workaround. You can use OverrideTexture passing in the default texture in the preprocess material as the first parameter, and your dynamic texture as the second.

Hello. Could you please elaborate on your workaround? I am confused by what you mean ‘OverrideTexture’. Thanks!

I’m referring to the function on UMaterialInstance here. Basically you assign any random texture from your game to the sampler in your Material. Then you acquire a pointer to that texture, and the texture you want to replace it with and call this function with your current feature level.

Thank you.

such an awesomely obtuse workaround

Thanks :slight_smile: it took me a while to find

Any blueprint workaround for this?

This has a fix for R4.11, just update your engine. Not quite sure which commit has it though.