Download

Post Process Material Quandary

Hello all,

I’ve been trying to get my head around an issue with the Ocean plugin and it’s underwater/split screen post process material. It was working for a long time and one day I realised it no longer worked in game - only in the editor. If I’m in the editor and I change it to “Game View” it again disables the effect completely. I’ve had a few thoughts on what might make this stop working and all I can think is something that is introduced in-game creates a conflict of some sort (i.e. takes over the custom depth process).

Has anyone had any similar issues or have any way that I can easily track down what might be causing the issue? I’ve tried going away from my main game map to test it, and it still doesn’t work so it’s not anything that’s placed in the world in terms of actors. I’m a bit stuck really!

I’d appreciate any insight or suggestions!

Edit: Just re-opened the test map for the Ocean plugin and it’s working under the water as it should… so it may well be something in the main game map. Again any suggestions I’d really appreciate, it’s annoying the crap out of me.

So I deleted my ocean blueprint in the map and put a new one in and it fixed it - good outcome, but still baffled as to why. I’d also tried resetting all of it’s values to default beforehand, but it made no difference.