Post Process ignores stencil mask

So i have this very nice mask

Nice Mask

that i use to nicen up the area under the ball that touches the arrow. the arrow uses a custom depth stencil to always be on top of everything except the ball with this material

now i have the problem that even tho the stencil is being correctly recognized


when i start the game it just ignores the mask and goes back to its original mask


any idea to fix this?

Do you have all of your stencil buffer settings in order?

Yes everthing is setup i just dont get why it suddenly ignores the mask ive made

And your custom depth stencil is set to 2 on the arrow?

yes the PP works fine but it just ignores the mask

Perhaps it’s a matter of the post processing mask materials Blendable Location? It seems to only draw over transparent objects if set to “After Tonemapping”

hm tried uesing different but couldnt get the result i wanted

This is what I’m getting (set black to green on my material)

OH okay i was just stupid i didnt plug the script into the event tick everthing works now my bad :grimacing: