Download

Post Process - DOF issue

Hi!

My issue is pretty straight forward;
I enable DOF in a post process volume - nothing. No DOF effect no matter which values.
All other effects in the volume works just fine.

Whats even weirder; it doesn’t work in 4.5, but works just fine in 4.4.
I did a clean re-install of 4.5, but the issue persists.

Any suggestions?

Hi Joki,

DOF is correctly working on my end.

Make sure that you have the post process volume set large enough to work in the area you want, or if you want this to work for you entire level you’ll need to select your post process volume and in the details panel check the box next to “Unbound” to make the settings true for the entire level rather than the area inside the volume.

Here are some values I set for test cases in Content Examples using a unbound post process volume:

DOF using a Shape Tetxure

DOF_BokehShape.jpg

DOF using Gaussian Blur

DOF_Gaussian.jpg

I agree. It should. The setup works fine in 4.4, but not 4.5. No matter the values.
8f3ef5e4c92e59c791e24c80990ea321be5009ea.jpeg

Here are the results of my test with your setup in 4.5.1:

dba5c142c868fc9e5448492be820ba79b56ea762.jpeg

There are two ways to use your Post Process as I mentioned above. You’ll want to increase the volumes size to encompass the area that needs to have these Post Process effects or you can check the box next to Unbound so that the Post Process is used for the entire level and does not require the size of the volume box to be increased.

If you check the “Unbound” Box you will see the same results. If you’re still having issues please try the same setup in another project to verify that something has not happened with your specific project.

Thank you!

Tim

Yeah, it’s either that Unbound tickbox or your player camera’s PP settings priority is set to a higher value somehow.

Thank you guys for your patience:)!
I understand what the unbound check box does and that the alternative is to create a volume that encompass the desired area.

Let me walk you through an example;
I create a new level in 4.4 using the first person template. In the middle of the scene I create a Post Process volume. I enable DOF + check unbound box. I play the level in viewport -> DOF is showing as expected.
There is no issues here. The volume behaves as it should with unbound checked on or off. Other Post process effects(tint, fringe, contrast etc.) works fine as well.

Now, if I do the EXACT same thing using 4.5, DOF is not showing, at all. All other post process effects which are enabled are working just fine, but not DOF.

I’m not saying its a general issue with 4.5, but rather something wrong with my install. I did try a clean re-install. But nothing changed.

Jacky; I tried different priority settings. I even tried applying DOF directly to the player camera. Nothing.

This whole thing is really strange i know, but i have no idea whats causing this…
Thank you again for your help!

Are all of your Engine Scalability Settings set to Epic?

nope, but that sure as hell did the trick!
Thank you:)!! Kinda feel stupid right now… but lesson learned:)

Here is an image of my test using the first person template in 4.4 and 4.5:

DOF_44_45.jpg

I’m not sure what may be going on on your end that may be causing this specific issue. Can you check your engine scalability settings and make sure that everything is set to Epic? I don’t think this will necessarily fix it since it’s not affecting the other Post Processes but worth a shot. :\

Here is my sample project with the DOF for 4.5.

Can you try opening this and see if you’re seeing the same results as before or if it working.

Do you have access to get the 4.6 preview build from the launcher and see if you’re seeing the same results there?

Let me know and we’ll start trying to rule things since this appears not to be a broken feature but something that’s specific to your machine and engine install. We’ll keep troubleshooting though!

Tim

Thank you so much for your help, Tim!
It was indeed the engine scalability settings that was the problem:)

Glad you got that working! :slight_smile: