Port forwarding for dedicated server?

Ok so I’ve compiled the dedicated development server, everything works perfect on my local machine, clients connect and see each other, so everyghin is just great, but?! How the hell do i actually make a port forwarding for that server? I mean i did it for port 7777, 7778 and so on, but since i don’t have any actual service running that is using that ports, they just stay closed for external connections.

I’ve searched all over the place but i can’t figure out how should i make it work, without a service runnig, or how should i make it a service that i can launch, so external people can actually connect and test it out.

Do you guys have any clues or maybe links? Thanks for any help on this question

Hi gonzamancg,

Due to the large volume of questions and comments concerning the Engine, we did not have a chance to respond to your post at the time you submitted it. However, if you are still interested, the following post contains a link to a tutorial posted by one of our community members and mentions port forwarding:

Working Open IP Multiplayer With My Game, Pics and Tutorial for Community


This post does not match the problem here, I have the same problem, the dedicated server is on, ports on the modem are open, firewall is disabled, but online port test services show me closed ports for my IP, the UE4 dedicated server does not travel data online, but only locally.

1 Like

If your server is using a domestic connection it is possible the ISP (Internet Service Provider) is blocking the port.

I tested this same port with a minecraft dedicated server and it worked correctly.

1 Like

Same issue, I tried to host a Minecraft server on port 7777 and it’s accessible from outside the LAN, if I run a dedicated Unreal server it doesn’t work, there must be something to change in the config files.

I noticed that websites to test ports doesnt return “open” for unreal engine dedicated servers, try package client and server both in diferent pcs and networks, it should works, sorry for bad english

Unfortunately, I wasn’t using a website to test but actual clients and servers for both unreal and Minecraft and it wasn’t working, I read it could be an issue with the Null Online Subsystem