Poor SpeedTree texture streaming

SpeedTree has too more drastically texture streaming. When I move closer it is good but when farther it looks awful. You can look at below screen what I say. When I change Streaming Distance Multiplier my tree looks strange like big hurricane.

Could you help me? How can I have better quality textures?

I am having this same issue, but not as drastic. It’s especially bad on the broadleaf tree types and all billboards.

The LOD ranges are 0.1, 0.05, 0.025 and 0.0125. Disabling streaming fixes it, but that isn’t a good solution.

Hi guys,

I’ve not been able to reproduce this with the sample Broadleaf asset from their site in the free pack. Can you provide a little more information on this one?

Are you using the broadleaf desktop sample from the Free 4 pack available on their site?
When you import are you using the default settings or changing anything? If so, can you tell me or post a screen shot of the settings you’re using to make sure I’m getting the same thing?

Also, what build of the engine are you both using? I’m currently testing this in 4.4.2.

Thank you!


I am on 4.4.2 and using the RedMaple and American Elm not one of the free ones. Though it happens on all the ones that I have with the broadleaf ones being the worst. As I mentioned, mine are not as bad as the OP, but still not crisp and clear as I would expect.

Here is a screen showing the RedMaple, Alaska_Cedar and London_Plane. There are a couple non speedtree conifer types in there as well, but I pointed out the RedMaple close and the Alaska_Cedar billboard in the distance:

I thought I would add an example of what I would expect the clarity/crispness of foliage to look like at distance. This is a random image of Cryengine I found in a google search. See the clearness of the foliage maps.

When standing right next to a speedtree things look clear and great, but something is going on with streaming/AA/filtering that just makes things “blobby” once you move away a bit.

Bumping this as it seems to have gotten lost again.

Have you changed the LOD settings of those trees? And are they placed with foliage tool or one by one?

In my case specifically I placed trees manually and changed the the LOD settings to:
LOD0 - 0.1
LOD1 - 0.05
LOD2 - 0.025
LOD3 - 0.0125

Got the same Problem. A few meters away from it and the Textures are just getting ugly.

EDIT: Okay If you disable TextureStreaming it works

Also had this problem.

I’ve got same problem also… not sure what to do…