Download

Poor quality light bake with Kitbash3d models & GPU Lightmass

Hello everyone! This is my first post here. I’m running into issues with the quality of my bakes. I generally seem to have better luck with my own models, but when using the Kitbash3d Neo Tokyo models something seems off.

In this first screenshot I’m leaving the meshes in their blueprints as Stationary. In this case I get some light after baking, but it’s relatively low quality (regardless of changing the lightmap resolution of the meshes in the blueprint). This is with GPU Lightmass’ GI Samples set to 512.

I tried changing the models inside to Static, which results in no baked lighting.

For lighting I have some emissive materials and Static spot lights.

I’m just messing around, but this is the look I was hoping for once you add some more lighting, more of a soft ambient look with a lot of bounce light, but I feel like even with a few lights mine just looks like a game, whereas this person’s render looks dusty and atmospheric. Any suggestions on how to get a more realistic render?

There’s more that you can do there to try and achieve the look you’re going for, some of it is just going to be some post process effects like adjusting stuff like bloom and adding film grain and all that. For that foggy dusty look you want to look into volumetric fog.

Besides that, you’ll want to have high quality assets, the ones there aren’t bad but having more details and things will help. Also look at the building windows, yours just has a solid color but a window would have some kind of texture to show an interior and have it lit up so there would be more going on with the windows.
You should also be using the meshes as Static, since they shouldn’t be expected to move or change. Otherwise they’re not getting the baked lighting. I’m not sure that using emissive materials as lighting works for GPU Lightmass though.

I’m not surprised, as these assets don’t have a lightmap! Did you make them?

Thanks for the tips! I figured I’d start with simple emissive windows since I’m a noob. I was hoping to get most of the atmosphere from lighting first before applying any post-processing, but maybe that’s not realistic.

Nope they’re not mine, they’re from Kitbash3d, which is the same kits the reference image I posted is using, so I’m kind of thinking I’m doing something wrong. I see that they do have a second UV channel when I inspect the model, but I have no idea what else to check :smiley:

Looks like they didn’t set the Light Map Coordinate Index to 1 instead of 0, that seems to at least resolve the baking-when-static issue! Any tips regarding the atmospheric look would be great, but I can continue tweaking now. Appreciate the help.

That’s what I meant, the didn’t setup lightmaps properly. You can get better ones just by re-running the UE system to make them from the UVs.

Gotcha, thanks! I’ll give that a try, I just migrated them over from the sample project they give you. I’m curious if GPU Lightmass has limitations as well since it has far fewer settings than CPU Lightmass, I might try switching over to CPU and see if I can get more indirect light

Just be aware the automatic lightmap generation feature in UE4 is not entirely automatic, it requires the seams in the UV mapping to already exist, it just copies the existing UV’s to a new channel and runs an flattening algorithm, if you don’t have UV’s split up already it won’t work.

The other thing about GPU Lightmass is that your GPU likely has less memory than your RAM and it will need to load all assets into that GPU memory and if it can’t it’ll crash.