Point light for skeletal mesh

Point light, with the option “Ray Traced Distance Field Shadows”, do not cast a shadow for the skeletal mesh. Movable light.
In this case, the light from the sun with “Ray Traced Distance Field Shadows” gives shadow (simple, but at least some sort).
Tell me, please, what can be the problem exists?

Hi Norealium,

Select your Skeletal Mesh and under the Lighting tab in the Details Panel select the option “Cast Inset Shadow.” This will enable the dynamic shadow for the skeletal mesh.


Hi Tim!
I have included this option, thanks to her were shadows under daylight. But from the Point light shadows still not (which I described in the first message) :slight_smile:

Actually, apologies here, I’ve just tested this and it looks like this may be a bug. I now seem to recall there being an issue that was reported with this. I can’t find the JIRA report for it currently, but I’ll see if I can dig that one up. I do recall this being a known issue though.

Sorry for the confusion. :confused:



I found an email discussing this with Daniel from a couple of months back. This isn’t a “bug” but just a missing feature. Getting support for skeletal meshes from point and spot lights will have to be added in the future. There is no specific timeline for this though.

again, apologies for the confusion.

All enabled…
Who tried to create a new project, and there from the very beginning to include too.
The result is the same - Point Light don’t cast shadows from skeletal mesh.

Oh, that’s great.
Thank you very much for your answers :slight_smile: Let’s wait for the update, it is one of the recent problems with the light in my project.

Since we’re talking about light: could you help me to solve another problem?
This time the problem is vanishing shadows from static meshs.
When you close the camera shadows look good and right, but when it starts to move away - shadows disappear abruptly. How to deal with it, or at least make the process smoother?

With this what you’re seeing is parts of the mesh being culled based on its screen size and thus with no mesh there to block the light you’re now able to see the light projected onto the back wall.

There are a couple of ways you could go about handling this.

  1. You can adjust the mesh bounds scale so that the mesh doesn’t occlude like that. I do not recommend this unless absolutely necessary. This will keep things around much longer than they need to be and if you do it on a lot of meshes it can cause performance issues. This is a straight up shove a rod in between the gears type method.

  2. The second method uses a spot light rather than a point light. Since the spot light is only shining light in the direction we would like you don’t have to worry about shining through the mesh when it occludes.

Here is an example using a spot light vs point light.

Right is Point light, Left is Spot Light



By using a Spot light you can not worry about adjusting bounds on a mesh and instead just adjust the cone shape and radius of the spot light to fit the same needs. If you look at the first image there is hardly a difference between the two with my quick adjustment of settings.

I hope this helps! :slight_smile:


Spot Light! Of Course! This is brilliant :slight_smile:
As I previously had not thought of, thank you very much, I am delighted: 3

Sorry to necro this, but I just did some googling and came across this same problem. Thisanswerhub question showed up in google, it linked to thisone, which links here.
Here’s a picture from a scene I’m working on:

The clay car on the left is a skeletal mesh with ‘Dynamic Inset Shadow’ set to true, and the clay tub on the right is a static mesh with a Distance Field. The point light is movable, and it has ‘cast distance field shadows’ set to true. Disabling the distance fields for the point light makes shadows show up for both the objects:

I’m wondering if I’m missing something here, or if this is still a feature WIP.
I’ve also created and enabled the capsule shadows for the skeletal mesh, but this doesn’t seem to do anything…

**Tim Hobson **Can you tell to your Epic Staff to implement Point and Spot Light Distance Field Shadowing on Skeletal Mesh while using Movable Lights PLEASE ?
We are making an Horror Game and we are stuck because of this not implemented feature.

@GeekToBe I have been able to fake this type of shadow by attaching mesh pieces (low poly) to the bones of the character. Those meshes can be hidden from owner, and only cast dynamic and distance field shadows, this is a little hacky, but it can work allright for shadow casting. My prototype uses spheres and cylinders, but it can be improved with custom meshes that look more like body parts.

You could just use capsule shadows, same idea, less of a hack.