Point light fade distance

Point light is faded out after some distance. How can I increase fade out distance of point light? I want small lights in far distance on scene. Thanks!

This option is called “Attenuation Radius” in the Light component options. Also you got “Use Inverse Squared Fallof” checkbox. It is On by default. If you disable it you will get more linear attenuation of the light, but be aware that you need to set intensity to something like 1-2 to not overbrighten the image. Details in the tooltip.

Unfortunately its not working. Lights far away from camera just disappear. I have to move with camera really close to light the up.

Hey thobias -

What are your point lights actually lighting in the distance? Notwithstanding the Light Bulb Icon, Lights can only be seen by their effect on the objects in the world. It could be that the object you are using to catch the point lights is LOD and culling out because of the distance from the camera itself.

Thank You

Eric Ketchum

Lights light up some windows on 2D translucent material or moon at sky. It’s prepared for 2D platform game. Ok, I’ll try change LOD settings… Thanks.

Try this command r.MinScreenRadiusForLights 0.01 (or smaller if it’s not enough, the default value is 0.03)


right, it works for me