Download

Plugin failed to load because module could not be found

i actually tried everything at this point
it happens on ENGINE’S BOOT, not when i try to play the level
Screenshot_1648

Are you wanting to use the plugin or is it just stopping your project from loading?

If you upgraded engine versions from 4.26 to 4.27 the plugin might not have support in 4.27 yet and can throw out that error. I’m not sure about that plugin specifically though, but I ran into an issue like this also and that was my issue. I had to keep using the previous version as sad as it was.

i didn’t, this is fresh 4.27 version, yes i want to use the plugin

Is this a source build or the engine version from the epic games launcher? Are you able to open any project or create a new project at all?

this is the engine version from the launcher, i’m not able to create any project right now, i’m able to open them. i understood the issue, i need a c++ project in order to open this plugin, but i have no idea how to make it so, because you can’t create a VR project with c++ code, only with blueprints

That is kind of weird… You should be able to create new projects…

You should be able to go to File> New C++ Class…> create an empty C++ class and put the new class inside > YourProjectName> Source> YourProjectName and that will generate a new cpp files and allow you to open your project in Visual Studio. You can build out those modules in there and open back up the editor and you should be good to go. That essentially converts a blueprint project into a C++ project, but will still maintain all your blueprints like they were.

If you plan on doing serious stuff with your project, I’d look at taking a leap into building the engine from source from a github download of the source which basically gives you the same editor, but allows you to do a lot more down the road. Its not quite that easy, but it’ll save your hair when you don’t have to try to move a project into a source build later wishing you started with a source build.

Beware though, a source build can be upwards of 200GB of hard drive space. Not including your project size…