Download

Please Help, I'm getting blue screen of death a lot! BSOD

Hi

i’m working on landscape which is not big 7x7 using grass type node to paint it with grass type node but while i move on the screen i get BSOD, i also get it randomly sometimes when i change to landscape mode or when imporing assets , it damged the file 3 times, i can’t work, i tried every fix on the internet for this, nothing helped !!

my spec:

Intel Core i7-9700K

NVIDIA GeForce GTX 1660 Ti 6 GB

16 GB DDR4 SDRAM 2400MHz

should i upgrade my ram to 32GB, will it fix the problem?

When you exceed your RAM limit it should start to use your Virtual Memory unless if that is configured incorrectly. Perhaps you have a performance problem with your hardware RAM during heavy loads.
If the hardware RAM is the problem then you either need to reconfigure it or replace them but the problem could easily start somewhere else like in a poor Power Supply or Motherboard or the Disk that is being used for Virtual RAM.

but if i upgrade my ram to 32GB will fix it?

Nope, you can check, how much RAM Unreal currently uses, directly in Unreal Engine and in task manager too. And before you buy new RAM, test your old for errors with RAM testers. But most of the time it´s Win10 screwing up and crashing itself into oblivion (aka just being Win10).

Well, I ran RAM error check with memtest86 and nothing wrong with my current RAM, UE4 sometimes takes almost 100% RAM, I close it then reopen it, the RAM usage become 50%

When your RAM is full,windows use virtual memory (VRAM)
If RAM + VRAM are full => BSOD

So first, the best thing is to increase the virtual memory, set it to automatic in system settings!
My experience with 16GB of RAM is that setting it auto is the best choice!
I don’t remember but in auto I think the VRAM will be at max 42 GB, when the VRAM reach 42GB => BSOD
I have try to set it manually at more than 42GB but when it reach 42GB => BSOD

Of course, increase your RAM will help 32GB of RAM + 42GB of VRAM is better than 16GB+ 42GB;
And Now I’m not sure that the limit of VRAM is 42 GB when you have 32GB of RAM

the vitual memory gives me only 20,48GB, is this normal or should it be 42GB??

In that case, maybe check, whats filling up your RAM so quickly, because that does not sound normal, or good. More RAM will only delay this problem, but if your RAM is full with just some items, it would only be a matter of time, if even your upgraded RAM is full.

I gave up on creating landscape in unreal, I’m trying to do a simple environment, as you can see now ue4 taking 70% RAM after just importing assets, and while i work i get the BSOD

this is the memory page

Looks to me like your system has some serious instability.
You can try running OCCT for an hour or so. If you get a BSOD your system is at fault. If you do not, then something is up with ue4 and your configuration.

Also, just because… dounlecheck your mobo manual. Make sure you used the correct ports for your ram. They are usually supposed to be in parallel distanced by one slot. It could be you added them next to each other instead…

And if occt fails you probably need to configure or check the ram from BIOS. Maybe it is running a wrong profile?

All things worth poking into…

Also I would remove any and all overclocking of anything at all.

well thank you all for replying and trying to help me <3 <3 <3 i will run OCCT and test it and see the result, i checked the RAM ports they are in the right place, i will update you when something hit up.

thank you again <3

Hello everyone !!

to whom will have this problem, it turns out i had a problem with my harddrive , it not reading right, i copy it to another harddrive and everything is working fine, there was no problem with my RAM

I had the same issue, when I would activate landscape mode it would bsod.

I figured out the issues,

#1. Make sure if running an nvidia gpu to install studio drivers

#2. Disable any cpu over locking
#3. Disable AMP profile

#4. Disable gpu overclocking

#5. Create a large page file in windows, I set mine to be 4000mb to 8000mb

#6. Make sure you have Visual Studio with the proper coding compilers installed.

Now reboot.

Unreal Engine should work as it should.