Download

Please Help - Can't make Dodo rideable

Hey there,

Could someone tell me what I’m doing wrong, while trying to make a rideable Dodo? I’ve added allow riding, etc. in the character BP.
I’ve also added Human_Male_TPV to a ridersocket in c_back3, and in the Editor itself, it works like a charm! I can ride the Dodo like it’s supposed to do.

However, when I cook it and try it out locally, it still puts my character in the wrong position and the wrong scale on the Dodo. At first I thought it was that the dodo_skeleton was being overwritten by the original file, so I’ve tried it with a new dodo_skeleton file which I needed to remap the animations to from the original file (seeing a static dodo walk around is a bit weird, and it made the editor/game crash). After I used “retarget to another skeleton”, the animation in the newly created dodo_skeleton worked, when I tried it in the editor, it worked again just fine, but when I cooked it and tried it locally, it crashed again…

Could anyone point me in the right direction or tell me what I’m missing/doing wrong?

Thank you in advance,

Ennylia

Is it working in PIE? Sometimes these things work in PIE, only to be overridden by hardcoded stuff. I’m finding that to be the case with the HUD.

Try modifying the core files and cooking a TC, assuming you’re not doing that already it may be worth a shot.

I have it working in PIE as well, with new skeleton, mesh, saddle and animations. But mine just refuses to upload - ive no idea why! Maybe we can put our workings together and solve it :slight_smile:

It works in the PIE just fine, it’s only in-game that the issue occurs. I haven’t tried TC out, because to my understanding a TC requires a full wipe each time the game has a major update, so personally that ain’t realistic for me.
I know it can be done as a mod instead of a TC, because I’ve seen one in the steam workshop.

Hopefully we can find out how to do this as it would be nice to ride a custom Dodo.

Have you tried copying a dino that is already ridable and changing the skeletal mesh?

Also it may be worth cooking a TC just to see if that is your problem. It actually doesn’t take too long if you have 201.6, they fixed the crazy cook times.

I have not yet figured out a solid step by step to get this working, each character I have done seems to require a different set of steps… but you essentially need to create a copy of the skeletal mesh, skeleton, animations, and animation blueprint.

Getting those to all work together can be quite tricky and frustrating though. Once you do get it working, you just need to set up your character_bp to use your animation copies, and then it SHOULD work on a server.

Maybe someone can tell me where I’ve been going wrong. My proccess has been:

-Copy Skeletal Mesh, Skeleton, Physics Asset (have also tried including colour textures etc) to new folder
-Assign Skeleton, Physics to the Mesh
-Adding saddle/player socket
-Copy and retarget All Animations to new skeleton. Same with Animation BP
-Ensure all animations etc are referencing to my new anim copys rather than the originals.
-Referenceing new animations in anim bp asset override
-setting new mesh, anim bp and anim motages withing the character bp

Doing the above makes it work fine within PIE. Ive also tried doing it without any edits to the skeleton, leaving everything as a copy of the default settings and i always get the same result - which is that is fails when i try and upload. This is the error i get (https://forums.unrealengine.com/showthread.php?80447-Steamcmd-Uploading)

-Copy Skeletal Mesh, Skeleton to new folder
-Assign Skeleton to the Mesh
-Retarget all animation assets to your new skeleton (I have had success with making sure all boxes are unchecked)
-Retarget animation blueprint to your skeleton
-Reparent animation BP to your copied dino animation BP(this sometimes works using the base BP, sometimes using the actual dino BP, but for some reason it needs to be “refreshed” to actually start making the animation “graph” work)
-Adding saddle/player socket
-Ensure all animations etc are referencing to my new anim copys rather than the originals.
-Referenceing new animations in anim bp asset override
-setting new mesh, anim bp and anim motages withing the character bp

It still takes a bit of fidgeting, but that is how I have gotten my resized dinos to work and look good. This one is SUPER frustrating to get working, but it does work, just keep trying :wink:

Sweet, I have been trying to get dodos rideable too… and it has been a pain the animation wasn’t working, but I think I forgot to retarget the animation blueprint. Seems like a lot of people have trying to get rideable dinos…

The next problem is re-scaling without re-scaling the rider…

I tried scaling the mesh rather than rescaling in the character bp… but it still rescales the rider for me…

Thanks for that. I think I will try to get my Boa work again after I get off from work.

@TheRealAzrael Ah it looks like ny mistske has not been unticking all the boxes when retargeting - I lool forward to trying this later :slight_smile:

Have a look at a dino skeleton that is already rideable. There is a player & saddle socket. You can copy and paste these to yoyr new dino skeleton. Youll find options to scale them there.

What do you mean by these?

In the editor and the PIE these steps works (indeed after fidgeting), but when I cook the mod and try it on a server (either dedicated or local), it still doesn’t work. The process of sitting on the dodo works, but the direction it sits in is to the left, while the dodo points to the right. Very frustrating… Also, when I tried editing the mesh, it comes out like a some kind of mutated Ostrich, with his tongue out of his mouth (very funny), but I can’t get those steps to work either…

I’ll try and post a quick guide for this:

  1. Make a copy from the Dodo skeletal mesh.
  2. Open it and go to the upper-right corner and press “Skeleton” (next to >mesh>animation)

OPTIONAL: If you want your custom mesh to have a saddle
3a. At c_back3, press RM-buttom “Add Socket”. Name it “SaddleSocket”
3b. At SaddleSocket, press RM-button and “Add Preview Asset” – Enter “SM_Sit_GenericSaddle”

  1. At c_back3, press RM-button again and for “Add Socket”. Name it “RiderSocket”
  2. At RiderSocket, press RM-button and “Add Preview Asset” – Enter “Human_Male_TPV”
  3. Select RiderSocket again and you’ll see the RGB directionals appear
  4. With SpaceBar, you can swich between rotating, scaling and moving. Place your socket (player) at the desired location. (TIP: you can also use this while in editor mode for a live preview)
  5. Save!

Hope this helps!! :slight_smile:

Okay, I think I’m pretty close with this one. I got the Boa to actually spawn, but its missing all the movement animations. All other animations that are referenced in the Boa BP work fine. What was this thing about “-Referenceing new animations in anim bp asset override”

Open the Animation BP, Go to ‘Window’ menu at the top and open the ‘Asset Override Editor’. In that window you can set all the animations to your new copied anims. This will make movements animations work, and also stop your mesh looking like a mutated ostrich :smiley:

EDIT: I just tried this step for the first time, but after unticking all the boxes as suggested above (never done it that way before) - and it hasn’t stopped the mutated ostrich affect. Its caused by the Aim offset anyway, you can uncheck it in Anim BP but im not sure exactly what effect this will have.

Alright, I will try that :slight_smile: I can’t believe I’m trying to do all this simply to hide the rider from the screen…

EDIT: Good news is that now the Animation BP is properly setup. Now I need to cook this and see if everything works out or not… Worked fine in the editor.

The mutated Ostrich effect hasn’t gone away, thanks for trying tho! I got all the steps working, except for that one. Does anyone else have any suggestions or tips on what we can do to solve our mutation problem? :stuck_out_tongue:

Alright guys, I got it to work with my Boa! I cooked the mod and it works just fine in the single-player. New rider socket and “invisible” rider. Boooyah! Thanks for everyone for the help!

Thanks, TheRealAzrael and Ennylia. Your steps helped a lot. It seems to be working in the editor and rescaling in the mesh isn’t changing the size of the rider, yay! To keep the dodo from looking like a “mutated ostrich” I had to reparent the animation bp to the base dino. I couldn’t use the dodo… This bothers me a little since the dodo seems to have 15 animation slots, while the Base has 13 and has a fall animations… which the dodo doesn’t…

Now I have to figure out how to change the weight capacity of the new dodo so it can actually move… XD

Edit: Wooohooo! I figured out how to add my own DinoCharacterStatusComponent to my new dino’s BP…

For others:

  1. Copy a dino’s DinoCharacterStatusComponent to your mod.
  2. Edit your dino’s BP.
  3. In the upper right click on “Components”
  4. Delete the old DinoCharacterStatus component from the component list.
  5. Click on “Add Component” and search for your modded DinoCharacterStatusComponent file.
  6. Play around with you Status settings. XD

EDIT 2:
Eureka! I can reparent to the original dodo animation bp. To get it to stop looking like a mutated ostrich just uncheck Use Aim Offset and Use Blinking in the Anim Blueprint Editor. For some reason those are bugged.