Download

Please give more control over Nanite culling per object

Even a 300MB decimated Zbrush mesh gets culled too much if Nanite thinks the geometry is flat enough. Unfortunately, this does not work well for cylindrical and more hardsurface shapes etc. Up close they are great looking, so it’s not an inherent problem of Nanite. But at a distance Nanite begins reducing these meshes far too soon compared to for example rock geometry with a noisy surface. So round shapes become too angular too soon.

Nanite works great for Hardsurface objects up close, so it’s just a matter of exposing some settings so Nanite creates more triangles for these meshes on import. (They clearly have far less tringles than the valley rock formations, even though they are very high polycount decimated meshes.

I tried out every settings that is available for Nanite (per object) and even changed the engine INI file settings. None of these solve this problem. Also importing the meshes at a larger scale does not change the triangulation of these meshes as far as I can tell.