Player start not working


I have a problem with my player start in the “RealisticRendering” level.
After I have made some alterations in the level (only added some static mesh actors) the player start is not working like it should. When I hit play the camera sits under the sofa and I cannot move the player or do anyting.
And I have checked all the following:

  1. Play Mode and Play Settings: Spawn Player at default player start and modes is on simulate (I have tried standalone game as well)

  2. I have tried these steps: 1)make a new game mode blueprint 2)open it and set default pawn to your player blueprint 3)compile and save it 4)click edit->project settings 5)and click on maps & modes 6)and set your new game mode blueprint as your default game mode

  3. PlayerStart is not overlapping with geometry

  4. The GameMode has the right classes set ( I believe, as I followed some tutorials and the previous step 2)

  5. World settings game mode override and default pawn class are checked as well.

I have watched many youtube videos and checked every Q&A on here and the internet and I can’t seem to find the answer.

I fear it’s probably something very obvious… but I’m at my wits end.

In a different level when I hit start the player keeps spawning in the air on a location far from where my playerstart is. Even when I have checked all the steps above.

Update: the issue was the playerstart was positioned at the front door of the house. I reposissioned the playerstart to the front lawn. The playerstart finally works which baffled me. Because I still could not understand why the tiny shift in the position would be so important. But that is because, now when I want to walk to the front door, the player gets blocked by an invisible shape. Which blocks a large portion of the level/landscape as well when I am in game mode apparently. Is there a way I could track down the invisible shape that blocks me?

try to print the thing that is blocking you,

example how to do that

Lardo, great example, thank you so much! It turned out to be a bit simpler for me. I activated show collision and the big problem was a pair of spectacles with the strangest simple collision ever. After I turned off the collision from that static mesh it solved the problem for me :slight_smile: