Download

Player/Character moves too fast, gravity is on but has no effect

I’m new to Unreal Engine, just three days in. So modeled a test scene, imported it, the scale is good but when I hit ‘Play’, the player moves around too fast. And there’s no gravity even though Gravity Scale is set to 1.0 in the details tab when Character and CharacterMovement is selected.

Show us how you’re moving the player and tell us what is your player.

Hi, thanks. Was about to delete this question as I’ve now found out how to add a character and access its walk speed. However now when I hit Play there’s no movement at all. Trying Shift F1 doesn’t do anything but offer a small blue trangle to click on, supposedly to enable mouse and keyboard movement but it doesn’t do anything.

We have no clue what you’re doing - it’s really hard to imagine what is missing.

Show us:

  • the script that moves the pawn
  • pawn hierarchy
  • how input is set up

Or look at any template that is using a non-character pawn.


Normally, for a non-char Pawn, you’d have something like this:

You provide direction and use axis & scale values to dictates input, the Floating Pawn Movement component interpolates it automagically and off you go.

But at this point we don’t even know whether you’re possessing (using) that Pawn. Essentially, more details please.

Input is set up as the default empty game scene comes. No changes except for adding the pawn/character and my models and deleting the default ground box.

So I dumped that scene and created a new one, imported the models again and now… when I hit Play I can move. But still too fast, changing the CharacterMovement walk speed in the details tab has no effect.

And there’s no gravity. The Character collides with the scene objects and can move about but that’s it. Hit the space bar to jump and you just stay in the air. Too fast and no gravity.

Unreal Engine - I’ve only had it 4 days so please assume no knowledge whatsoever, I’m an absolute beginner.

changing the CharacterMovement walk speed in the details

This is so confusing. Do you want a character with arms and legs, literally walking / running? Or is this just about moving along the ground and not clipping obstacles. Is this first / third person? Is it important?

No I don’t want a character with arms and legs, I just want to be able to move about without running. What is third person? I want to look out through the character’s eyes, not look at it.

And we’re looking around with mouse?

Yes.

Here’s the most minimalistic setup I can think of; and you don’t even need to set up controls for it, the controls are inherited.

  • right click in the content browser and create a blueprint based on the Default Pawn

  • double click this new blueprint and add the nodes:

  • and you can adjust the setting of the movement component

  • place it in the world by dragging it from the Content Browser into the scene

The end result in a blank project:

For something more advanced, you’ll need more stuff. Hope this helps a little.

Okay thanks, looks daunting but I’ll try. Is this the simplest way? Why don’t they give a character gravity when it’s enabled in the details tab? Seems crazy having to do all this for something it says is already there.

Following your picture I checked the Simulate Physics box. But there is no tab visible for Construction Script, where is that? Also with the Simulate Physics box checked, there is now again no movement at all. Back to square one.

I don’t need something more advanced I need something less advanced. I only need to move about at this point. With gravity, and not so fast that I run past everything in the scene in like 4 seconds. That won’t be any good for walking around inside a house.

You don’t need it.

Also with the Simulate Physics box checked, there is now again no movement at all. Back to square one.

Could you show how you’ve set it up.

That’s precisely the setup I’ve provided. But I’ll gladly accept the challenge of simplifying it further. :wink: Bring it on peeps.

As mentioned above, post a screenshots of how it looks like on your side - perhaps we can poke holes in it. Grilling people for details is not much fun :expressionless:

I am using UE5

I only created a blank game project. Then deleted the default ground box and imported my scene. Then created an empty character. Nothing else has been changed.

In the Details tab, the empty character appears underneath CapsuleComponent (CollisionCylinder) (Inherited) and Mesh(CharacterMesh0) (Inherited).

I can select the CapsuleComponent and check the simulate physics box in the details tab. This time, doing that has no effect at all.

I can select the character and adjust the walk speed. This has no effect either.

I’ve just dumped the entire scene and started a new one for the umpteenth time this morning.

No fun, you’re absolutely right there. Sorry for all this trouble and thank you for helping. I can do screenshots but only of what I just told you. I haven’t changed anything else in the default blank game.

But this is completely unrelated to what I suggested… Are we doing something else now? You did not follow any of it, did ya?

If you really can’t stand placing 4 nodes down:


The native character does not have any movement implemented afair. So you’d need do it all from scratch. The easiest way would be to open the fps template and copy stuff from over there. But that’s closer to 50+ nodes and needs setting up the controller and the game mode blueprints to boot.

Think about it, how can the engine possible know which keys you want to use for movement.

The little flying pawn that you can normally zoom around is the Default Pawn - there the controls are implemented at C++ level - it’s the same little thing that you can use when you navigate the scene outside of the game.

My suggesting was to use what already exists so you do not need to do anything else.

No I couldn’t because there’s no Floating Pawn Movement visible in the details tab.

Okay I need a while, maybe I need to delete the Empty Character and create an Empty Pawn.

Because I’m using IE5 and you’re using another version things look a little different, so I was trying to follow anyway.

UE5 is in Early Alpha and not ready to develop anything. Probably fine for learning. What we’re discussing works the same way, though.

maybe I need to delete the Empty Character and create an Empty Pawn.

As in the very first image. If you want a character which sports a much more advanced movement system, you will need to communicate your will to its movement component. That’s some busy work. It’s set up quite nicely in the fps template, thought.

There’s quite a lot of tutorials that deals with that:

The beginning of the tut create a character from scratch.

Thanks - okay here I don’t know what sort of Blueprint I need to create… or how that is to be based on the new Empty Pawn I just created.

I’ve created the Blueprint Class you red arrowed .

So now Pawn has DefaultSceneRoot underneath it.

I select DefaultSceneRoot - still no Floating Pawn Movement in the details tab. Not surprising because in your picture you have MovementComponent (inherited) selected.

Where is this Blueprint I just created? Yours says NewBlueprint(self). I don’t have one, or at least I can’t find it.