Download

Planes as walls for modular level

Hey guys,

unfortunately i’m sitting here for like 3 days trying to fix my problem.
Basicly i am working on this game right now, and it involves modular level.
For that my wall-meshes needs to be set to “moveable” so the dynamic lighting takes over.

As for my mesh i use a simple plane, created in cinema4d. This i exported to ue4.
Now when i place the meshes in a straight line (everything is perfectly flush),
i still have light “bleeding” through the connected walls.

Also the shadow doesnt seem to start at the bottom of the wall. There is a bright line.
I even put the walls inside the ground, but that doesnt change anything.

Things that i already tried/did:

  • read forums
  • searched google
  • put light map res to rediculous values
  • set mesh/material to 2-sided

This all results in either me not having shadow at all.
Or the pictures that i attached :frowning:

any help would be highly appreciated
PS: sorry for bad english, not my mothers tongue.

It seems that default shadow resolution is too low for movable flat modular assets, so you may try to increase it with console variables r.Shadow.MinResolution 2048 and r.Shadow.MaxResolution 2048 (lightmaps resolution doesn’t affect dynamic shadows). It’s not good for performance, but I don’t know better solution for your problem

I am not using c++ to place these meshes.
Currently i got a little function in my level-blueprint that places the walls.
Where would i do that in a blueprint? Or can i do these settings in the mesh-properties?

To activate console variable fo current session you should press ~ on keyboard and copy/paste it to the text field. For permanent use How to set a higher shadow resolution permanently? - UE4 AnswerHub

I think you should model your wall not as a plane but as a solid object. This way the back and side planes of your wall will prevent the shadow gap.

Thats another funny thing, even if i use the standard primitives (2 boxes) from ue4, i get a slight gap between the shadows, although they are perfectly aligned.
This bright line at the bottom disapears, but yeah having 2 separate shadows aint really looking that pretty.