Download

Plane mesh not casting shadow

Please help I already tried everything enabling 2sided shadow and setting the material to 2sided.

Hmm, hard to tell at the moment:

  • Is the shadow baked or dynamic? Which is to say, is the light itself static, stationary, or dynamic? Is it casting both static and dynamic shadows, or just static?
  • Are the meshes static or dynamic, and do they have static/dynamic shadows enabled?

@SuperfuntimesV
Light is all dynamic. light has both enabled: static and dynamic. Meshes (the sphere) work with either static or dynamic. Yes static and dynamic shadows enabled.

Sorry for the delay in response!
Hmm. I’m not sure:

  • Any kind of opacity happening on the material? Subsurface? I assume it’s just surface/opaque/default_lit.
  • Something happening regarding shadow distance on your key light, there? Cascaded shadow maps, for example?
  • Is it perhaps only working in a specific channel and/or is the object only using one light channel? As in, they’re both using channel 0 or whatever?
  • … I’m scraping the barrel, but something happening with a reflection cube…? I don’t think that would affect it but just throwing out more ideas.
  • Are the normals correct? Are the UV normals reversed?

hmmm this one is like a riddle. Is this your plane from a modeling package or an Unreal plane?