planar reflections With illuminated walls

I’m trying to make a mirror with planar reflections but my walls and floors are appearing super bright. It only disappears when I turn off the “deferred lighting” option but my glow materials do not have texture, how do I solve it?
image 01

image 02

Did you build your lighting?

yes, This bathroom wall is only 1 object

I already managed to clean

I experienced something similar and it looks kinda like planar reflections arent picking up baked shadows for some reason. I have an exterior with a little lake in a valley. The sides of the valley are in shadows and it reflect correctly as long as I am so close to the “walls” that they still get the dynamic shadows from the sun. But when I move away and it fades over to the baked shadows, those are missing from the planar reflection then.

It may be a planar angle setting, what do you think?

Hmmm…good catch, I will have a look at that :wink:

planar reflection

how did you fix this? I’m having the same issue, but deferred lighting does not help.


The problem is that I was using two directional light

Planar reflections does not support dynamic shadows for direct light source. Turn cascaded shadows for direct light source to 0.