Planar Reflections - not working properly in VR

Has anyone used the new Planar Reflections feature (from 4.12) on an HMD yet?

I know it’s probably not recommended as Planar Reflections essentially render the scene twice but I would like to use them in a VR project I’m working on and have found an issue with it.

The good news is - they do render properly and look fantastic. The bad news is - they don’t lock to the rest of the material when the headset’s in motion. It seems the geometry they are rendered on (in my case a lake reflecting some terrain) does lock to the HMD and update at 75fps (on a DK2) but the reflection texture seems to slide around when there’s any motion on the headset. This ruins the immersion unless the head’s perfectly still.

Planar Reflections are extremely new and are probably a work in progress but I was wondering if anyone else had noticed this issue / has a workaround or any of the Epic staff know whether or not this is something that will be resolved in a later version?

I’m on 4.12.2 and using a DK2 with the 1.4 SDK.


I tried it and had the same problem. The performance hit was big though so i doubt it’s much use for vr.

Thanks for the reply Magneto.

It’s definitely useful in our case - but then it’s for an experiential application so we’ll have control over the hardware and can afford the extra rendering cost.
I doubt the fix will be high on the list of priorities for Epic, as you say there is such a performance hit that PR+VR is probably not in much demand.

Still it would be nice to understand why it’s happening and whether it’s something that could be reduced, hacked or potentially fixed in the future.

Hopefully someone else will have an answer to what’s happening…?

it looks like they have yet to implement a late update on the render thread for the planar reflection camera which is causing the discrepancy in latency when you move your head. I hope that they look into sorting this out as I have scene’s that can definately use PA and still hit framerate.

So you think it may be down to timewarping? That makes sense as it doesn’t drop below target framerate and is more noticeable the faster the head moves.

its weird how all you guys just seem to be speaking about latency. for me - planar reflections on the Oculus Rift cv1 are just way off, and STAY way off. Its not about latency, it`s just that the reflections are not where they are supposed to be

they look fine on desktop , but on the HMD they are just all off.

Am I missing a setting or do I need some adjustments in the placing or size of the planar reflection actor ?

I’ve got the same problem - I ended up doubling all the geometry and mirroring it. This wouldn’t work with much animation though, and I ended up with tons of polys.

I already had multiple cases where we needed planar reflections working in VR for the studio I work for. So I’d really appreciate it being fixed!

I have the same problem. My scene is very simple and a planar reflection improves a lot the final render. I tried with UE 4.13 preview 1 and it hasn’t changed.

Hey, same situation here, we need planar reflections in VR, but the lag is BIG!

No solution yet???


…just found the thread while looking for a solution. Working in 4.14, seems planar reflections are “detached” from the material and move weirldy when you move your head in VR. Guess devs are aware of the issue, just wondered if there more source for info/fixes.

1 Like

it’s weird that you have reflections that are not good in VR. I have no reflection at all when i am on VR mode, but they are there in editing mode. M i missing some settings because i don’t see any reflection even that bad reflections that you are talking about. i am on ue5 and i still have the same probleme.

Make sure you have the global clip plane support enabled if you want planar reflections.