Planar Reflection Distance Mobile

Planar reflections seem to do be disabled after a really short distance on mobile. Where is the setting to change this “disabled” view distance? All the settings on the component itself don’t seem to do much, like distance from plane fade and angle from plane start. Is there a console command for this clipping distance? Right now I need to be right on top of the object (with ~20cm), which is usually not the case.

This is what it looks like on mobile:

I tested it on multiple devices with this project:

I hope someone can tell me what I’m doing wrong or if this is just a bug.

got the same problem, trying to fix this…

Can I ask what devices you are both using when you’ve tested on?


Using your test project, when I add the Planar Reflections actor I’m not getting it work on my end at all. I’ve not used it on Mobile that much so I might be missing something at the moment.

So far I’ve tested with an Iphone 5s and a Galaxy S6 and S4.



Tested using Galaxy S4 android lollipop.

Did you check the option in Project Settings → Engine → Rendering → Support global clip plane for Planar Reflections?

That has already been enabled, just having to see why it’s not rendering for me on multiple devices. I’ve used them in standard projects, just not mobile up to this point. Thanks for letting me know which device you’ve used.

I’m getting the same issue. Tested on Nexus 9 and Nexus 5.

A fix or workaround for this would be amazing.

Solved it.

What you want to do is make sure the reflecting mesh is only a single plane.

The template maps (as pictured) all ship with what are essentially boxes as the floors which will not work on ES2 renders.


Make sure your material is 1 sided and facing the right way.

It will also require (unfortunately) Mobile HDR to be enabled. Also make sure you place the Planar Reflection actor in the scene (as I’m aware the OP’s Testing project, above, didn’t have this)

When I tried it, it was with a custom mesh, just a simple plane. It didn’t work.

I can’t test directly on my device right now, but I do have a 1 sided material. Mobile HDR is enabled and I do have a planar reflection. I’ll try to make more tests tonight.

Edit: Did some testing. I needed to check Planar Reflections on the mobile section of the material.

I tried the reflections on two scenes.

Scene 1: Same problem as OP. In editor: it works. Mobile preview: depend on the distance. On the device: Everything is black and/or renders incorrectly. But this scene was not built with mobile in mind so it’s all right.

Scene 2: It works on my editor viewport, but not on my mobile preview, nor my device. I built this scene from scratch to test mobile capabilities.

The steps to make planar reflections on mobile are:

  • Change target hardware to Mobile,

  • Enable Support global clip plane for Planar Reflections,

  • Enable Mobile HDR,

  • Place Planar Reflection Capture Actor in scene.

Is that it? Or i’m missing something…

Edit: Need to check Planar Reflections on the material on the Mobile section.

I went ahead and submitted UE-32905 for this issue. It seems like it should work with actors that are not just single planes, although that is a good workaround for the moment since in my test they do not have the issue as pointed out earlier in this post.


It was the material option setup that I missed. thanks for pointing that out.

i am getting clipping object in reflection after planar reflection actor, in picture you can see i am vewing in mobile mode, i have also checked on mobile its same , i have also tried above all methods not working