Download

Planar Reflection Bug Forward Rendering

Hey,

We are using two Planar Reflection Actors. One on the Floor of the Warehouse, and one that is inside a small Room suspended from the ground. The Planar reflection actor on the Warehouse floor is reflecting parts of the warehouse, and the one inside the room is reflecting certain contents of the room.

(Note, we are limiting which meshes are being captured and reflected using the* “Use ShowOnly List”* property on the Planar reflection actor.

In the Deferred renderer this works as expected. However in the Forward renderer it is broken - only one of the two actors is capturing and reflecting its contents.

The actors appear to be fighting for precedence, as whenever we change a setting on one of the actors - it disables and the other one activates.

Screenshot/description attached below.

Advice/guidance would be much appreciated, thank you!

As far as I know, you can only have one Planar Reflection enabled at a time using the Forward Renderer. I read this somewhere but can’t remember if it was official documentation or a forum post.
I get around this by setting up Trigger Volumes to disable/enable the Planar Reflections I need throughout a given level. So possibly in your case you could have a transition moment between the warehouse and the interior space where you disable the outside Planar Reflection and enable the interior one.

If there is another way around this limitation I would love to know myself.

It seems that now you can have only one planar reflection when using forward rendering. I can confirm that in 4.20 and previous UE versions, forward rendering supported multiple planar reflections, but now it seems that 4.22 and newer versions only supports one. Maybe this limitation can be changed from some .ini file?

I also think that Occlusion Culling is not working as intended anymore with Planar Reflections (Deferred rendering also) It feels that Planar Reflections are eating more performance than before. Use “show only list” always helps ofc.

I am using 4.25 but I can´t get the Trigger Volumes to work. The planar reflections turn on and off but the reflection is not there… Are you just placing the planar reflections on the level or are the a child of some blueprint?

I’ve done it both ways, as an actor placed in the level and as a self-contained BP. The key is there can’t be more than one planar reflection activated. So my trigger volume first disables any other planar reflection in the level and then enables the new one.