Download

Plan V Tools - Virtual Production

Marketplace link

A set of virtual production tools designed to be used both in editor or in a packaged scene.

Description

Plan V Tools comes with a controllable camera system that will easily turn any level into a navigable 3D environment that can be packaged and shared across team members, clients … It was designed to package some features you’d typically only find in editor such as taking screenshots and multipass renders (Lit/Unlit/Normals/ObjectID/Depth), toggle layers (VFX / Set / Studio / Characters), a timeline to playback any level sequences, and a storyboarding tool. These are all tools that tend to be very useful to artists across industries who don’t want to learn Unreal Engine to have a quick look around a 3D environment.

In addition, some of these tools are also accessible directly in-editor allowing for users who are already working in Unreal Engine. For example, the storyboarding tool can easily convert boards into level sequences allowing you to go from the idea stage to the final render stage within a couple of clicks.

Features:

  • Storyboard tool
  • Screenshot tool
  • Layers tool (VFX, Set, Studio, Action)
  • View modes (Unlit/AO/ObjectID/Normal/Depth/Light)
  • Virtual Camera tracking and recording
  • Panorama tool (High resolution 360° screenshot)
  • Techvis tool (measure and render techvis screenshots)
  • Sequence player (playback sequences at runtime)
  • Ability to package tools into an executable for use without Unreal Engine.

Known issues:

  • Widgets cannot be edited via blueprint (causes Editor crashes) => Edits can be done in UE4.25 and brought over to 4.26.

  • Panorama Tool doesnt render a full image => Navigate to Plan V Tools Content / Editor / Other, open TED_CubeRenderTarget, then tick and untick the HDR tickbox. Save and try again.

  • Unreal Remote 2 does not connect on 4.25 => No solution so far.

Last updated 02/02/21:

Update 02/12/20:

  • General bug fixing
  • VR compatibility (including packaged builds)
  • Can now create notes & measures in packaged builds.
  • Note actor improvements
  • Storyboards, notes and measures can now be exported out of a packaged build and reimported in editor.

Update 19/10/20:

  • General usability bug fixing and tweaking.
  • Added Panorama Tool (360° renders).
  • Added Techvis Tool.
  • Added Take Recorder integration (to record Level Sequences).
  • Added camera tracking with Steam VR headset or any of the two controllers.
  • Added camera tracking with Remote Session and Unreal Remote App 2 on IOS.
  • Added camera tracking with Virtual Plugin and Virtual Plugin app on Android.
  • Added Note actor.

Hi, I bought this plugin last week and installed it today. Fresh out of the box, looks to be broken. Is this being worked on? Anything I can do? Thanks

Hi there,

It seems the TakeRecorder plugin isn’t enabled in your project (Plan V Tools should enable it automatically).
Try enabling it as followed:

  1. Go to Plugins
  2. Search for the TakeRecorder plugin
  3. Enable it and restart the editor

We will be pushing an update in a couple of days, we’ll make sure this issue is solved.

Thank you!

EDIT: The update has gone through, this issue should now be solved, make sure to update the plugin via the Epic Games Launcher.

Hey, thanks for the reply but it appears that the TakeRecorder plugin was, in fact, already enabled in my project. I disabled TakeRecorder, Plan V Tools, and Virtual Production Utilities and then re-enabled all of them to see if that would jump start it but no such luck. Sounds like I may just have to wait a few days for an update.

I have same TakeRecorder problem. I hope the fix is coming, maybe with 4.26 update?

Hey there,

Did you make sure the TakeRecorder plugin is enabled? If it is, could you try disabling it and reenabling it before restarting the editor (it will say Plan V Tools needs it, just temporarily disable it too).

It should automatically be enabled when activating Plan V Tools but it seems to be oddly inconsistent.

EDIT:
We found two temporary solution. We are working on a fix.

  1. With the project opened, find the PlanV_Tools folder (you might needs to enable Show Engine content), go to Blueprints/Components right click Takes_Component and under Asset Action, do Reload Asset.

  2. Move the plugin from *Epic Games\UE_4.25\Engine\Plugins\Marketplace\PlanV_Tools *to your project folder [Project_Name]\Plugins\PlanV_Tools.

The latest update should have solved this problem, please get in touch if it you’re still getting issues with this.

Update notes 02/02/21

4.26 Compatibility

Plan V Tools is now compatible with Unreal Engine 4.26. All editor and runtime tools (including packaging and VR) should all be working as expected.

There is currently one known issue, the Object ID viewmode will only render in one eye (affects only VR mode).
It has been flagged to Epic, we’ll update the plugin as soon as we have a fix.

****Variant Manager ****

Plan V Tools now is now compatible with Unreal Engine’s Variant Manager (see Official Documentation). The editor side allows level and set designers to set up various layouts and object arrangements in the same level. Once set up, these variants can be toggled in a packaged build of Plan V Tools.

**
https://lh3.googleusercontent.com/I5GWhTDZlgHoyVAOmRJv13X-sTc62BcT6Nv9M2JrSonr1cYD2lGXM1yp_wNAIwe97RO28GkOaMITAkz0qHGE18cdHBcV5Ec0-RXdsZIF5S5wWA2T2hj02kSG08d0AcS3mVbewS8t
​**

Recording tools

Several tools to facilitate the live recording of cameras were implemented. When using Plan V Tools in-editor, a “Record Tool’’ button is visible on the top right of the screen.

Save / Restore Camera State: Saves the current position, focal length, film back, active sequence and start frame allowing you to easily reset a shot.

Attach to object: You can now attach the camera to any moving object in the scene by holding shift and clicking on an object. The camera will follow its movement while keeping the ability to move around it. This can be useful for any vehicle shots, where the camera has to follow the vehicle at an offset.

**
https://lh4.googleusercontent.com/kAXVC1vhuPK_ployRLG2ogbhv-Uoaq_vDi9FitN2-rptiBcetkHyb_8lvMKraK6vL6J-sL0gsjyeuN2Bjw8UaWN7vRbYptdTQyqfOSwV8XRhLG3E53nht4e-fLQXxGYk8e2tTjJD
​**
**
https://lh5.googleusercontent.com/OdLWj5i0gsUXlXoJQy34Ym1d0glhkYDzDJtBeF5BW67q7B61a3kIbfV39uPw30imaNwfjzX9jhVmz0lszCMdajcXVHgRjxaxl05CjyOULyo0MUgfs0V4ARuR6GfctKS6apX4Xsds
​**

Improved timeline

The timeline has been slightly modified and now features a search bar, optional filters and the ability to look for sequences in the project rather than the ones in the level (enabled via plugin settings, for editor only). Filters can be activated by nesting sequences in a folder with the tag “PVT" or "PVT”.

**
https://lh3.googleusercontent.com/HJj6p8KG0ihCkAP_PYUR5zFjbHoowJV-2bfjnZoI8oplrgqz2GoFfFoNxXhdKHuz9N2LwQX14GkKhXPVMPGM4un9ZN_ijKG_Zi8gcCAmPDVmromIth9u-cbw55e5K5hNYazjPgTa
​**

VR Updates

VR mode has had a couple of tweaks including a better screenshot tool, improved navigation and the ability to display the controls by holding B.

Please note that we have switched to an Oculus Quest 2 for VR development, and although Plan V Tools is still compatible with Steam VR there might be some slight inconsistencies depending on the headset.

**
https://lh4.googleusercontent.com/PIfbfbmq9RHi5PgLac82fMTd8GKB_cTVqPiCcQXoQ7d5dv3GAURA1X0nRiRracLUGpSXfMsiSAwDMw2vD_cAo3jh2NQ8SmWf0bMWg0nQOoseFMAmWKWR--ZLIOPEgM4W7iBMHuoU
​**

**
https://lh5.googleusercontent.com/iEdUBK2AnOz7W3EJqbn-hbZsZKosC01i_dxeuThHat_U0ktJpAMgeD0x6kpql6mbTLmrNp0OoMQ7UJpnmq0T3IgZi82pFRKpwCroCYuqQ3kVRNY8gefmrZADQ-NVKyr9wkhK4kz8
​**

Storyboard

Sequences can now be linked to storyboards. Saving shots while playing a sequence (in editor and at play) will now save the playing sequence and the current frame. Pressing the “Go To Camera” will now not only restore the camera position but also the animation that was playing when the shot was saved (if it still exists). Moreover, converting a storyboard into a new level sequence will automatically add these animations and time them accordingly.

Virtual Camera

We can now use live link sources to control Plan V Tool’s camera. Simply set the device selector to live link in the Virtual Camera interface and make sure your source is connected as a Transform source.

Following recent updates to the Unreal Remote 2 app, using an IOS device isn’t as simple as it used to be. On 4.25, these devices are now only used for tracking purposes. On 4.26, in order to get the tracking and touch input, IOS devices need to be setup as live link devices.

Other updates

Take Recorder errors: This issue, caused by direct references to the TakeRecorder plugin should now be solved.

**Movement settings: **Additional movement settings were added such as camera and movement smoothing and 2 new movements modes (free and locked camera).

**Editor camera tool: **Some slight improvements were made to the editor Camera Tool including camera presets which were originally only available when running Plan V Tools.

**In-game controls: **Controls are now displayed by either clicking the controls reminder (top right of the interface) for keyboard and controller or by holding B or Y in VR mode.

**Collision warning: **The collision warning was toned down, and now only displays a small pop up message.

Thanks for the update. I still have a problem. If I record with take recorder and after that render the final video clip with sequencer, there is always the PlanV user interface also rendered in the picture. I can’t prevent that. How to do that?

Hey,

Changing the game mode used to render the sequence would fix this.
In the Render Movie Settings, find the Game Mode Override setting and set it to **GameModeBase **as shown in the screenshot below.

Thank you! It works now. I spend whole evening trying to record video clip with take recorder and using sequencer and movie render queue. I managed to make it work somehow. Also I have ByOwls virtual plugin for android and it works fine with PlanV. A simple tutorial (maybe into youtube) about how to use take recorder with Plan V and how to render final video clip would be helpfull for many.
Only way I could make this work was:

  1. Start PlanV
  2. Open Take Recorder. Put there CameraActor
  3. Move in PlanV into place you want to record.
  4. Start recording.
  5. Stop recording. There seems to be CineCameraActor now in take recorder.
  6. Close takerecorder and PlanV
  7. Open recorded Scene in to Sequencer. Unlock animation lock in the right side. Add CameraCut track. Put there CineCameraActor. Save.
  8. Render clip with sequenser or movie render queue.

Yes that’s pretty much the workflow when using Plan V.

However you don’t need to manually open the take recorder and add a camera, Plan V Tools will automatically populate TakeRecorder’s sources (the actors that will be recorded) with a CineCamera (that matches what you see on the screen) and any animation that you are playing via the plan v timeline while recording.

A tutorial for this is a good idea, we’ll try get one up soon!

That is the problem, at least I have that: take recorder opens, but it is not populated by anything. I have to put there something myself. Could you check if there is something to be done, some setting or something in the plugin?

Okay, I’ll be looking into it, can you tell me what engine version you’re using?

Also, when you run Plan V Tools via the Plan V button, can you see an actor called “PVT_TakeRecorderSources” in the world outliner?

I use the newest 4.26.1. Yes I can see that PVT_TakeRecorderSources.

I just made a new test level and in the first start the window in below popped up. I started it anyway. It seem to work similary as my previous level. Take recorder opens when I click recording, but it is empty.

Well, I can manage with it now that I have learned how but if there is something you can fix in next update then that could be fine.

This is a cool plugin for recording a virtual camera movement for video.

Wow those compilation errors are quite unique! We’ve sent a new update which has fixes for both TakeRecorder and some of the VR components. It should be available to download now via the launcher now.

If the update doesn’t fix the issues, could you send us a copy of your log file?

  1. Open project
  2. Start Recording using Plan V Tools’ recording button
  3. Stop recording and close project
  4. Navigate to [ProjectName] / Saved / Logs and pick the latest .log file.

You can post the file here or send it to dev@paintingpractice.com if you prefer.

I sent you email.

I am also wondering isn’t there anybody else having the same errors, or is it just because of my computer.

Thanks for the log!

For anyone else with corrupted blueprints, reinstalling the plugin should do the trick.

As for TakeRecorder, the record button might need two presses if the TakeRecorder panel isn’t opened or visible.

I would like to remove the view modes from the passes panels and just want to see layers, but when i delete it form UMG and BP when i restart unreal im hit with a fatal error and have to reinstall the plugin

how can i remove pieces safetly ?

Fatal error: [FileD:/Build/++UE4/Sync/Engine/Source/Runtime/CoreUObject/Private/UObject/GarbageCollection.cpp] [Line: 2671]

AssembleReferenceTokenStream for Class /Script/TakesCore.TakeMetaData called on a non-game thread while GC is not locked.

can I get some help, please. anytime I edit anything in this plugin and I restart unreal it crashes on startup with the following error

I have tried copying to project plugin folder still the same error

Fatal error: [FileD:/Build/++UE4/Sync/Engine/Source/Runtime/CoreUObject/Private/UObject/GarbageCollection.cpp] [Line: 2671] AssembleReferenceTokenStream for Class /Script/PlanV_Tools_Editor.PlanV_ActorSourceRecorder called on a non-game thread while GC is not locked.

UE4Editor_CoreUObject!UClass::AssembleReferenceTokenStream() [D:\Build++UE4\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\GarbageCollection.cpp:2671]
UE4Editor_CoreUObject!TFastReferenceCollector<FAllReferencesProcessor,TDefaultReferenceCollector<FAllReferencesProcessor,0,0>,FGCArrayPool,6>::ProcessObjectArray() [D:\Build++UE4\Sync\Engine\Source\Runtime\CoreUObject\Public\UObject\FastReferenceCollector.h:660]
UE4Editor_CoreUObject!<lambda_b92b346365f5853c1d2c64b33bfd56a0>:perator()() [D:\Build++UE4\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\ReferencerFinder.cpp:121]
UE4Editor_CoreUObject!ParallelForImpl::TParallelForData<TFunctionRef<void __cdecl(int)> >::Process() [D:\Build++UE4\Sync\Engine\Source\Runtime\Core\Public\Async\ParallelFor.h:177]
UE4Editor_CoreUObject!TGraphTask<ParallelForImpl::TParallelForTask<TFunctionRef<void __cdecl(int)> > >::ExecuteTask() [D:\Build++UE4\Sync\Engine\Source\Runtime\Core\Public\Async\TaskGraphInterfaces.h:886]
UE4Editor_Core!FTaskThreadAnyThread::ProcessTasks() [D:\Build++UE4\Sync\Engine\Source\Runtime\Core\Private\Async\TaskGraph.cpp:1065]
UE4Editor_Core!FTaskThreadAnyThread::ProcessTasksUntilQuit() [D:\Build++UE4\Sync\Engine\Source\Runtime\Core\Private\Async\TaskGraph.cpp:888]
UE4Editor_Core!FTaskThreadAnyThread::Run() [D:\Build++UE4\Sync\Engine\Source\Runtime\Core\Private\Async\TaskGraph.cpp:965]
UE4Editor_Core!FRunnableThreadWin::Run() [D:\Build++UE4\Sync\Engine\Source\Runtime\Core\Private\Windows\WindowsRunnableThread.cpp:86]