Download

Pixelstreaming (4.23) UMG widget events not triggering in lower third

Hi,

We are currently implementing a Pixelstreaming solution, but we run into an issue where UMG widgets do not respond to the mouse clicks or hove in a certain region of the screen. We only noticed when trying to run it on a Windows server using -renderoffscreen -forceres resx=1920 resy=1080. When then trying to use the UMG buttons on the right side and bottom of the screen, they don’t accept any events.

When trying to reproduce it locally on a Windows 10 desktop, with a clean Unreal project, to avoid possible specific settings in our project.We were able reproduce the same behavior, setting the resolution to 3840x2160 for the Unreal instance, while the display was set to 2560x1440.

Here’s a screenshot of the test project, where we can still click on the buttons inside the red outlined area, but below that, the buttons don’t respond to any events anymore:

I tried a lot of scenario’s, changing the anchors of the buttons, adding a safe zone, changing DPI scaling, change ratio, but none worked.

So I’m hoping anyone of you had encountered a similar issue, and know a solution or work around?

Thanks in advance for your help!

Have you tried a newer engine version? In 4.25 and 4.26 it works perfectly fine.

Thanks @Zeblote for your response. We also see that it works in 4.26 and we will start testing with that. Unfortunately, a lot of our project still depends on 4.23, so we cannot immediately upgrade. But at least it is good to know it works in 4.26. Still curious though, what the difference is. But since it is 3 major versions off and PixelStreaming was still experimental in 4.23, I imagine I won’t find an easy answer for that.

We’ll just have to move our upgrade to 4.26 in our timeline