Pixel Streaming Not Working

Hi Guys,
I followed the exact tutorials mentioned in the documentations for setting up the pixel streaming
Node.JS - is properly installed
88 and 8888 Ports are also Open
My laptop is ACER Predator with Intel i7 8th Gen | Nvidia 1050ti | 8GB DDR4 Ram

I have package the game properly and also followed the step for creating the Shortcut and
adding -AudioMixer -PixelStreamingIP=localhost -PixelStreamingPort=8888

I started the Signaling Server by running the run.bat file.

But whenever i try to access the ![alt text][1]Game from my Local IP address it tells me
WebRTC connected, waiting for video

I am using the Chrome web browser a![alt text][2]s well

Please check the Attached image as well

After completing all the steps first run the game on your system then try to access it with chrome. It should work and if you want to connect it without running the game in foreground on your PC add -RenderOffScreen to the shortcut file where you have added all the other commandline parameters.

Hope I am correct I also just tried it out few days ago but it worked for me after following all the steps.

Also hanging on “waiting for video” using someone else’s project, I discovered that it was caused by ProjectSettings> Engine> Rendering> Default Settings> Frame Buffer Pixel Format set to “8bit RGBA” (Config/DefaultEngine.ini r.DefaultBackBufferPixelFormat=0). Resetting this to the default “10bit RGB, 2 bit Alpha” or “Float RGBA” fixes pixel streaming.

Try disabling your Firewall.


I have an issue. I am unable to send double click event from pixel streaming. Consider i have an object which needs to double clicked for collapsing it works in packaged game but not via pixel streaming

i followed all steps but still nothing works. the console doesnt give anthing else after i opened the game via the shortcut with parameter " -PixelStreamingIP=localhost -PixelStreamingPort=8888". opening localhost only shows click to start

This sounds like a similar issue to which applies to 4.27 and on AMD graphics cards. I’m experiencing the same issue at the moment with 4.27.2, using the latest SignalServer and AMD RX6800.

I ended up resolve my issue by setting Project Settings → Platforms - Windows → Default RHI to “Direct X 12” instead of “Default”. Did a write up here Workaround Pixel Streaming 1.0 on AMD: fatal error, EXCEPTION_ACCESS_VIOLATION, crashing, blank screen and "webrtc waiting for video"