Pitch black meshes lighting problem

Hello! Suddenly while I was editing my project I realized that in my level several elements (doors bp, curtains, some window sections) appeared completely black. Even these having static lights nearby.

This is the strangest thing of all, the door is completely black, it doesn’t seem to be affected by the light, but if I move the light nearby, it instantly illuminates the door in the editor. Then, I do BUILD. But just after calculating, it turns black again.

  1. IMAGE: When I move the nearby light on the editor, the door lights up. Unreal asks me to do a build in red. That’s how it should look, the door lights up by a nearby light.

  1. IMAGE: Once the build is done, this is the result. The door appears to be painted with Vantablack even with the light next to it.

I don’t quite understand how to solve this. I’m still learning.
All help will be well received :slight_smile:

Thank you very much!
Have a nice day,


If those meshes (like the door) are static meshes then there will be some problem with the lightmap! …I’m guessing it has a blank map…
Could you show the lightmap uv of the door please?

I’m going to go crazy with this, please help. I have deleted all the scene elements to get more speed in the build and it keeps happening. These are the UV of the door and the respective config.
The door only lights up if there is a dynamic light nearby. If it’s static, it’s completely black. Does anyone know what may be happening?



The first door has heavily overlapping uvs!!
Both doors have 2 uv channels: are you sure you are using the correct channel for lighting?

1 Like

Your lightmap settings are wrong, open the static mesh and under General Settings change your lightmap coordinate index to 1, it’s set to 0 which is your first UV channel which has overlapping UV’s.

Also, you should be using Stationary lights, especially if your door is going to end up needing to open and close because then it won’t use baked lighting for the door and the static light won’t light up a movable mesh.

1 Like

lightmap coordinate index to 1

Thanks!! That fixed the problem :slight_smile:

I would like them to be stationary but I can only have 4 overlaps. For an interior at night, a horror game, in a house, I’m having a hard time. Also for performance. Between lightning thunder, room lights and some effect, the lights overlap in certain areas.