Physx Normal map problem

Hi All,
Having some trouble with adding any PhysX cloth to my character.
The normals change once i apply the clothing to the element see the result I’m getting on the left as opposed to having no cloth applied on the right. I have tried smoothing, softening and hardening the mesh within maya to see if that would help however does nothing and I always end up with the same result.

Ok so I’ve found that if i change the normal map mode to ‘world’ it gets rid of the ugly black bits however the quality is no where as good as the normal mesh.

Hello joshmalosh,

This process can be a bit tricky since it deals with an external program. There some important settings within Unreal that need to be applied in order for your Apex Cloth to work properly.

Your issue seems to be related to the Textures and Materials, but your issue could also be with your mesh settings as well. To make sure, try and use this image I posted as a reference as well as have a read over the documentation provided. You can also open the ‘Content Examples’ project, and within the ‘Cloth’ map you might be able to find something there you possibly overlooked as well.

Clothing/Import Settings

Mesh Mode Documentation

One thing to note. Be sure within the material you are using for the clothing asset, the ‘Used with Clothing’ and ‘Used with Skeletal Mesh’ are checked. If you have tried these suggestions, and are still having this issue, let me know and we can troubleshoot further.

Cheers,

Andrew Hurley