Download

Physics with sequencer

hey guys

sorry to be a pain asking but new to UE4 and its amazing btw.
I am using it mainly to create cinematics, but although I have watched a lot of tutorials recently, I cant find anything about physics in the sequencer.
when I have a ball rolling down a hill for eg, if I hit alt s for simulation it works fine, but wont have the dynamics enabled when I play back the movie in the sequencer. could anyone give me some tips please or point me in the direction of a good video explaining this please?

I have the simulate physics box checked in the objects properties but don’t know what other settings I should be looking at.

thanks for any help.

any ideas please guys?
cant get the physics to work in camera with sequencer, the objects just stay there but fall and act like they should when I use simulate??
Been looking on the web and youtube and cannot find anything. can this be done please?

Is the physics object something that is being controlled by Sequencer, or is it completely separate to anything controlled by sequencer? If you’re explicitly setting actor transforms using sequencer, that will be overriding any physical simulation that tries to move it based on collision or gravity.

Sequencer doesn’t explicitly disable physics simulation, so you should at least still be getting collision events where necessary.

sorry I don’t think its controlled by sequencer as I am new to UE4 so I don’t know exactly how to do this. how would I enable physics with an object in my cinematic please?
any tutorials out there please?

You can find all the documentation for physics in UE4 here, and there are a few video tutorials you may find useful here and here.

thank you so much :slight_smile:

watched those tutorials and sorry but nothing that helped me.
all I want is to keyframe a physics action in a sequence and it should be simple…
I love UE4 and think so much stuff is amazing right out of the box but cannot figure out this?
in blender its pretty easy to achieve so I thought this would be very easy in UE4

Not sure if this is what you’re looking for, but I just made a simple scene where I have 2 cubes. One of the cubes has a transform track that just sets two keys on the Z channel. If I PIE, the cube animates as I expect and then hits the other cube and they both bounce around.

I turned on “Simulate Physics” for both of the cubes. Also, make sure that both have “Mobility” set to “Movable”. (Note - Sequencer will do this automatically for the cube that has the transform track).

Sequencer_Physics.jpg

Thanks Max, will give this a go, thank you very much for taking the time to reply.
What I am trying to achieve is, say for eg in my cinematic, the hero moves forward and some rocks fall down in front of him, I want to trigger or keyframe this, this is for a movie, not gameplay, so if I check use physics, then I PIE, the rock falls really nice but when playing my shot 1 in sequence for e.g., then nothing happens?
I could of course animate the rocks, but if there is a lot of them and also using the physics makes it look and fall more naturally.

yeah still a no go in sequencer. there must be some other step I am not doing to make this work.
do you think I need to add an event/blueprint to make this work please?
or is there any checkbox/option that needs to be ticked? I thought a keyframe to turn off physics then one to turn it on should do it, but alas no!

I’m not sure. Can you post a screenshot of your set up?

What are you actually animating in sequencer? Is it the hero forward motion? Both the hero and the rocks have “Simulate physics” toggled on? And “Mobility” set to “Movable”?

1 Like

Thanks for replying Max. and really sorry about this as I am still new to UE4. (from after effects and blender background)
Ok got some success at last. I put in some rocks and spheres, adding them to sequencer and enabling physics, then I keyframed the physics also in sequencer, I built the scene (not sure if I had to do this) and then when I played back the simulation it works great but in my camera when I play back, nothing, the objects stay where they are and don’t react?

BUT when exporting the movie, everything works as intended, so that’s cool, but is there any way to see the physics simulating in my sequencer camera please as I need to check my timing of the shot and camera angles.

When you say play back are you hitting the play button in sequencer/viewport? Or are you in PIE? You’ll need to be in PIE and make sure there’s some mechanism to trigger playback, ie. AutoPlay the level sequence actor or hook up some blueprint to play the level sequence.

ahhh that’s where I am going wrong. is there any tutorial on how to do this please?
the physics work fine when I export the movie but I want to preview them through the same camera and angle that I am using for sequencer.

Try Simulate mode:

https://docs.unrealengine.com/latest/INT/Engine/UI/LevelEditor/InEditorTesting/

That should allow you to scrub and hit the play button in sequencer/viewport. That’s essentially what happens when you record a movie. It’s autoplaying the sequence in PIE.

If you’re looking about how to get a level sequence to play at a particular moment, look at this:

https://docs.unrealengine.com/latest/INT/Engine/Sequencer/HowTo/TriggeringSequences/index.html

Thanks so much, will check this out. Thank you very much for taking the time to reply Max :slight_smile:

ok I think I know what I need but as I am new to UE4 I don’t really know how to make it.
Could I make a blueprint which when I press spacebar to play my cinematic, to turn on simulation at the same time please?
as if I turn on simulation then goto my camera and play the sequence, I miss the start of the physics action.

So basically a blueprint to start simulation the same time as my sequence :slight_smile: anyway to do this please?

OR - when I hit simulate it uses my sequencer camera…

There should be a way to do this.

Sounds like you might need a camera cut track to tell sequencer to switch to a particular camera:

https://docs.unrealengine.com/latest/INT/Engine/Sequencer/HowTo/TracksCameraCut/

To play your sequence from blueprint, take a look at the documentation in the previous post about “Triggering Sequences”

thanks again Max, nope I cant get it to work.
it seems simple on paper lol and I am sure there is a really easy solution. its prob me not explaining myself properly. when I play my sequencer movie, I just want the physics to react like they do when I play simulate, maybe this is not possible?

I came here to find the solution… sadly there is no solution for this :frowning: