Physics with sequencer

yeah it seems this should be very simple but seems really hard…
just want to play physics in the camera view just like its gonna be when I export the finished cinematic.

OK so when I select cinematic viewport and click on the camera icon, the physics will play through my camera but I have to scrub through the timeline. Is there not a way to play the sequence and physics BOTH together does anyone know please?
So when I press spacebar to play my movie, the physics will start.

Can you package up your project with repro steps? I’m not quite understanding what you’re seeing. You can send me a private message with the path to the project. Thanks.

Thanks Max. Ok I think I have finally found a workaround. I make sure cinematic mode is on, also loop playback range, then when I think the physics will start in my scene I hit the play button.
Not perfect but a lot better than trying to guess. Would be nice to have a function (blueprint maybe) where the simulation starts same time as the sequencer playback.

Any ideas of how to set up a blueprint to do this please?

I am attempting to throw a destructible mesh against a wall, then have it break up and fall after impact.
Because this mesh is keyed (the flying motion towards the wall), “most” of the physics is disabled. I say most because the rock seems to be falling in slow motion after it completes its key instructions. Is there a way to “disable” transform instructions at any point in the timeline so that the actor can be released to perform its physics function? Or if not, can you recommend an alternative?

I have similar issues and can’t figure out How to use Physics in the Sequencer?

Video shows & explains the problem:


I have this problem too and i use this :

  1. open Sequencer recorder
    2.add physic objects
  2. disable " Start awake" in details physic objects in simulate mode
    6.Start recording “Sequence Recorder”
    7.move a little physic objects with mouse
    8.wait to finish animation
    9.stop "Sequencer recorder "
    10.hide physic objects in outliner (disable visibility or move to layer and hide layer or delete ) recorded cinematic and set camera
    12.render movie.


1 Like

three years later I am looking for similar solution. It should be simple: make cinematics that have physics in them. In my case I have a car with wheels and physics constraints. I can follow tutorials that show a wheeled car with wheels rolling with friction on terrain(in a game). But in a cinematic you cant transform the position of the car with simple keyframes and use the same constraints to get the wheels to behave ‘physically’ in a cinematic ? the idea here is that unreal should be a tool for stoyboarding in cinematics, but use the physics constraints to do some of the animation.

vehicles don’t really work that way. You could potentially try to tie them into an AI controller.

I have used physics within sequencer several times before. Its not that it doesn’t work, its that more often then not it can’t be scripted unless you recorded a sequence prior and just play it back (Exact example given above your post).

So, to do it with a car, this becomes:
record the sequence while playing as the car, or
make an AI controller and order the car to move on a nav mesh while you record it.


could someone find the solution? I came here with the same problem

HI there!, I’ve got the same problem. I can make my character die in the scene using the sequencer as you will see on this video:

but, I can’t recording the sequencer content for cause of use the PIE mode (in this case, the simulate mode). Any found the way to resolve this? I think all the unreal physics are more orientated to the playgame and not for cinematics production. Otherwise, probably using blueprints or some programing, you I will get this but I don’t know about it.
Any help to resolve this will be appreaciated. Thank you so much in advance!

1 Like

Same here! I just want to activate the global simulation at a given point in my sequence. Isn’t that possible??

It’s so annoying that the simulation starts as soon as you press render: the first frame of my output sequence actually shows my animations already started.

I just want to be able to render my whole animation!

Thanks in advance

It is so absurd, I have been digging into TAKE RECORDER and sequence recorder…

And they only record AFTER you press play (to run the physic simulation…)

It’s like if the actors of a movie would begin acting before the director says “action”.

Is it not possible to take-record (and therefore render) a WHOLE action with its physics from the beginning??

Epic positions UE as a filmmaking tool now as well but these oversights are really baffling. You absolutely need a way to bake physics for cinematics, so you can scrub and see how everything interacts. Also, the simulation has to be 100% the exact same every time, there’s no room for RNG in filmmaking.

i have the same problem… epic need solve this :c

Hi guys…

I have been facing the same issue.

Project setup: A simple sphere at some height in a level.

Expectation after adding Simulate Physics: Ball starts falling down when I hit the play button in sequencer

Reality: Ball stays stuck in space

Solution (not sure if this is the way to do it but it works): Use the green level play button at the top of the viewport to start the engine (presumably starts the tick and all). Then play the sequencer. Your camera settings and all are preserved and the simulation is visible in the viewport.

If this is a bit confusing, let me know. I can record a short video of how to do this.

Hope this helps…

Finally FLIPSIDE 3D sorted this -

Is this cache manager thing new to UE5? Works great in sequencer now.

1 Like