PhysicalMaterial.SurfaceTypes not saving

I’m trying to set up some custom surface types as explained here in the Surface Type section. In the editor, I’ve tried going to Project Preferences → Physics and setting the custom types using the dialog. Unlike when I change the Input section, which immediately updates the DefaultInput.ini file, changing the surface types using the dialog doesn’t affect the DefaultEngine.ini at all. I’ve also tried manually editing the DefaultEngine.ini file by adding the following-

[PhysicalMaterial.SurfaceTypes]
 SurfaceType1=Glass

-but I cannot access my custom surface type in the EPhysicalSurface enum in C++, and the Project Settings → Physics dialog does not recognize the addition.

After looking through the ShooterGame DefaultEngine.ini, I found that its config notation was different from the documentation:

[/Script/Engine.PhysicsSettings]
+PhysicalSurfaces=(Type=SurfaceType1, Name=Concrete)

As far as I know everything is working codeside now, but, although the entries I manually added to the ini file show up in the Project Settings dialog, I still cannot edit the settings from the dialog. It is only a mild inconvenience to edit the config manually, but it’s something that definitely should be working regardless.

Hey James-

Is this still occurring for you in the most recent version of the engine? Where in the DefaultEngine.ini are you defining the PhysicalMaterial.SurfactTypes?. Are you able to use the custom surface type in blueprints or does it not work there, either?

Cheers

Doug Wilson

Hi James,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

Thank you for your solution. It is still working under 4.7.3 but nothing has changed in the documentation yet.

Edit: Then again, looking around in the editor, we now have a menu in the Projects Settings / Engine / Physics to add our own entries. Could be worth it to document this feature on the same page …