Download

Persistent Level Content No Longer Showing When Running Standalone

Hope everyone had a great 4th of July! I’m having a slight problem when playing my game in Standalone Mode in that the content within that level is not showing. I can see my pawn and the directional light (which is from the persistent level) reflect off of it but everything else doesn’t show that is contained within the Persistent Level. This actually was working this week and only became a problem when I added a level for streaming to serve as a background maybe 2 or 3 days ago. In my Level Blueprint, I call Load Stream Level and load the level that serves as the background and it shows perfectly with the content from the persistent level in PIE, New Editor Window but when I go to Standalone Game so I can test it out with the Oculus Rift, I only see the background level content within the game and not the content from the Persistent level. Could this have to do with some odd resource contention between the two processes since Standalone serves as a secondary process?

Now when I tried to remove the level that is streamed in to be the background and disconnected the Stream Level node in my Level Blueprint, I now can’t unfortunately see anything and before I was able to at least see the content within the Persistent Level. Just for reference, I am running 4.2. Thanks guys!

I’m try to test this out right now and it seems as though it has nothing to do with level streaming and that it is simply that my Blueprint is not created when running the level in ‘Standalone Mode’. I saw someone posting something similar in the AnswerHub forums but they thought it was related to casting an instance of a given object. I do some casting in my Blueprint but it worked before when I did that and I also for extra measure added a Print String right after the Construction Script is supposed to hit but it never gets there. I also stuck one in to call for every Tick and nothing appears in Standalone but everything works great in every other mode of play within the editor. This basically worked fine in Standalone for this specific Blueprint in 4.0.1, 4.1.0 and 4.1.1 but I am running 4.2 and no luck. I haven’t upgraded to 4.2.1 quite yet since it takes a lot of time to get everything setup and recompiled and was waiting for 4.3. Is there any reason why a Blueprint wouldn’t get created in Standalone Mode and only the other Play options? Thanks

Be sure to check your log to see if a compile error is happening. I’ve run into several instances of my blueprints working fine in-editor but not in the standalone game. SOMETIMES, the log will generate an error for you about what failed, but isn’t terribly detailed. Try this too: Open the editor and load your level fresh without opening any assets up. Hit play and see if there’s an error or something. That’s helped me find some problems before.

Hey Tom, thanks for the response and suggestion! I checked it out and I’m not getting any errors or warnings at the moment. I went through the log and everything was looking good so no clues there unfortunately.

Okay, well now things are starting to get weird. So in one of my Blueprints inside the Construction Script, I process a ForEach loop and depending on a variable ‘Count’ and vector ‘Distance Between’, I create x number of instances and space them out from one another. Well in Standalone Mode, if I process this once and ignore my initial ForEach, it works up to the point that I call ‘Add Relative Location’. If I don’t ignore the ForEach loop, it doesn’t show period. So something is wrong and/or is a bug within UE 4.2 from at least what I can tell. It simply isn’t making sense why the ForEach would cause this or the call to ‘Add Relative Location’. Can someone from Epic help me out, this is a critical issue that I need to resolve shortly. Thanks and keeping my fingers crossed! :slight_smile:

UPDATE: So the ‘Add Relative Location’ works if I don’t supply my ‘Distance Between’ variable but works if I remove the pin, ugh, this makes no sense… is it possible something is corrupt?

2nd UPDATE: Okay, my Blueprint is definitely corrupt and/or this is also associated with a bug in 4.2.0. I said above that my ‘Add Relative Location’ only worked if I didn’t wire up a reference to my ‘Distance Between’ vector, which should work without a problem. Well, the pin I grabbed from the ‘Distance Between’ vector was one that already existed in my BP Graph, so I had an idea of dropping a brand new ‘Distance Between’ Get Property Node and wired that up and that ‘Add Relative Location’ now works. I really need some clarification from Epic on this since it seems like I am going to have to do a lot of deleting and re-adding of nodes to hopefully get things back. Is there a way to force a rebuild of Blueprints, and I mean one that isn’t tracking what changes need to be updated but a full refresh. Thanks again.

3rd UPDATE: I tried going over to the ForEach and recreating a new node and even just simply setting the start and end indices to 1 so that it only index 1 would get processed. Mind you, in order to get this to work previously, I jumped over this node. However, even adding a new one in and rewiring it up had no effect so the ‘Distance Between’ one may be a singular case and I’m dealing with something different for the ForEach blocking my BP from being executed. I do know that this exists in more than just this place as I found this issue in another BP as well. It’s technically probably not corrupt due to the fact it works great in the editor or any other play mode but something is definitely broken.

Any ideas? I also have this posted to the AnswerHub forums but no response there yet. [Critical Bug] - BP Corrupt or bug in 4.2.0 w/ Standalone Mode - UE4 AnswerHub

Thanks!

UPDATE: As a update, I tried this last night in 4.3 and no luck :frowning:

2nd UPDATE: So what I am doing is going through the one of my main Blueprints in question that is having these issues and I am literally moving the exec pin forward in the chain to find where the problems are happening. In each area that I am going through, I am literally re-creating nodes that are failing and that is working so something is definitely corrupt about my Blueprint. It’s odd because everything works great in the editor but something is definitely wrong with UE4 if the nodes causing the problems are being worked around by recreating and wiring them the same as before with absolutely no changes. I really need to know if there is someway to clean out all the compiled code and recompile this thing from scratch.

EDIT: This thread should probably be moved to Blueprints or another forum since it probably doesn’t specifically relate so much to rendering as I initially thought, thanks :slight_smile:

Have you tried reparenting your blueprint to some unrelated class, then reparenting it back to the proper one and recompiling it?