Download

Performance Problem

Hi, I’ve been fiddling around with UE4 recently, and it seems like I’m getting really low FPS, considering the specs on my machine. My current environment is mobile level of low res in terms of modeling, and not even half of it is textured, but the FPS seems really low. I am currently testing out the new GI, and my FPS go down to under 20 (in the editor and not in standalone game test mode it’s around 26-28). My texture resolutions are all as low as I could get them without seeing pixelation. If anyone could help me troubleshoot why I’m getting such low FPS that would be greatly appreciated. Let me know if there is any info you need from my test level that would help.

My computer specs:

i7 4960x
24gb ram
tri crossfire with 7990+7970
(Testing in 1080p)

Thank you very much!

PS - If this is in the wrong section, sorry, I didn’t know the best place to ask this.

I don’t think crossfire works in windowed mode. You need to be full-screen to utilize it and you cannot run the editor in fullscreen. But your 7990 is a powerful card even in single gpu mode so I am not really sure why you are getting low fps…

Oh yeah, forgot about that part, but yeah, still seems really low. I’m not at home right now, but when I get a chance I’ll test it out fullscreen. Thanks.

So I tested it out again, and it seemed me putting it into full screen by pressing alt-enter, did absolutely nothing, the frame rate didn’t change. It is like the engine isn’t even detecting or using the hardware properly. Is it something I have to do on my end, or something that just isn’t patched? I was going to be trying to make a PC quality game at some point, and if my top of the line PC struggles with these small things, I don’t know how I could.

So I just made a brand new clean scene, the one that just has a cube platform and the standard lighting. I get 45 FPS only when looking at the platform mostly, and my machine can’t even hit 60 when looking up at the sky. What’s going on? Help please!

Rather than creating a new scene, create a new project, and see what kind of performance you get there. If it’s still bad, honestly, I’d imagine it’s something going on with your computer. I have an I5-2500k with 16gb of RAM and a single GTX 660, with no issues. Creating a new project is sort of a litmus test - if it’s better, you know something is off in your project files/setup (maybe the project settings, general settings, framerate?)

Just made a new project, first person template if that matters, I got around 40-50s FPS when just looking around. My video card isn’t being used at all from what I can tell. I don’t know what to do… cause I can’t make anything like this. :frowning:

There are a few things to check:

If you play in a new editor window or stand-alone, check the Viewport options before running and make sure that Realtime is unchecked, otherwise (it seems) the editor keeps updating in the background, which effectively cuts the framerate nearly in half.

Also check your Scalability settings: Effects and Post Processing seem to be the most demanding on my system, and dropping them to high or medium typically makes a huge difference. Resolution Scale can be dropped below 100 (try 75) if you are getting a low framerate when running tests in fullscreen.

Finally, make sure you don’t have any Blueprint event graphs or other separate editor windows open while playing, because they too seem to be chewing up cycles even when they are technically supposed to be idling in the background.

I do most of my prototyping on an i7 laptop with a very modest GTX 460M GPU and a measly 6 GB RAM, but using the tweaks above, it’s typically possible to get a usable framerate in the +30’s on somewhat simple test maps.

If you play in a new editor window or stand-alone, check the Viewport options before running and make sure that Realtime is unchecked, otherwise (it seems) the editor keeps updating in the background, which effectively cuts the framerate nearly in half.
-It seemed like a good idea, but unfortunately it had absolutely no affect on framerate.

Also check your Scalability settings: Effects and Post Processing seem to be the most demanding on my system, and dropping them to high or medium typically makes a huge difference. Resolution Scale can be dropped below 100 (try 75) if you are getting a low framerate when running tests in fullscreen.
-When I test fullscreen my tri-crossfire should take into affect and give me at least 2-3x the framerate, but it doesn’t change at all, like it’s not being used.

Finally, make sure you don’t have any Blueprint event graphs or other separate editor windows open while playing, because they too seem to be chewing up cycles even when they are technically supposed to be idling in the background.
-Nope, all closed.

Thanks for trying, I really appreciate it. There must be a setting somewhere that is limiting my hardware or something, cause if anything, the fact that the video card isn’t being used, especially in full screen mode, is pretty much proof of that.

I totally blanked out - I believe there is an option somewhere to choose which display adapter is being used, and it’s possible you’re using integrated. Take a look here: Multiple Graphics Adapters (related to 4.1 QFE / very low fps rendering) - General Discussion - Unreal Engine Forums

It seems like it is reading everything fine, and I don’t have integrated graphics. Here is my log script (Well a part of it):

[2014.06.14-23.28.18:227] 0]LogInit: CPU Page size=4096, Cores=6
[2014.06.14-23.28.18:227] 0]LogInit: High frequency timer resolution =3.526181 MHz
[2014.06.14-23.28.18:228] 0]LogMemory: Memory total: Physical=23.9GB (24GB approx) Virtual=8192.0GB
[2014.06.14-23.28.18:228] 0]LogMemory: Platform Memory Stats for Windows
[2014.06.14-23.28.18:228] 0]LogMemory: Process Physical Memory: 59.47 MB used, 59.47 MB peak
[2014.06.14-23.28.18:228] 0]LogMemory: Process Virtual Memory: 32.75 MB used, 32.75 MB peak
[2014.06.14-23.28.18:228] 0]LogMemory: Physical Memory: 4675.09 MB used, 24514.43 MB total
[2014.06.14-23.28.18:228] 0]LogMemory: Virtual Memory: 294.84 MB used, 8388608.00 MB total
[2014.06.14-23.28.18:600] 0]LogD3D11RHI: Found D3D11 adapter 0: AMD Radeon HD 7900 Series (Feature Level 11_0)
[2014.06.14-23.28.18:600] 0]LogD3D11RHI: Adapter has 9103MB of dedicated video memory, 0MB of dedicated system memory, and 12001MB of shared system memory, 1 output[s]
[2014.06.14-23.28.18:600] 0]LogD3D11RHI: Chosen D3D11 Adapter Id = 0
[2014.06.14-23.28.18:614] 0]LogRHI: Texture pool is 1361 MB (70% of 1945 MB)

So I did some more tests, when I press alt-enter in a standalone game launcher to test my level in full screen, the other two video cards aren’t being used. So clearly crossfire doesn’t work with UE4 at all, unless there’s a proper command to enter full screen mode I don’t know about when testing a level. When I have a completely empty level, literally nothing in it, and I look down at the grid, I get about 112 FPS only, less than 60 when the window isn’t in focus, but that’s an engine thing I presume which is understandable. During this my video card is screaming at 100% usage. How? I don’t know, but this seems like it shouldn’t be happening on a much worse set up.

My friend did a test in Unity cause he has in installed and on a far far weaker machine, and he was getting 2100-2300 FPS in the same kind of void.

I doubt you are going to get any real benefit from crossfire when it comes to using the UE4 editor. All of my experience when it comes to ATI and crossfire is that THEY (ATI) has to add support in on the driver side for you to get ny real benefit. Forcing it in on your driver side will give you a small gain but nothing like when ATI adds in real driver support.

Also I maybe wrong but I think running the editor in fullscreen mode will not trigger crossfire to kick in. It’s not an exclusive fullscreen mode that would kick in crossfire.

Something to check though is that under your project setting > General Settings > at the bottom look and see if Smooth Frame Rate is checked or not.

I use to run two 7870’s in crossfire and it was the worest experience ever playing games. From working sometimes to not working other times. Microstutters, and odd graphic glichs. I was glad when I moved over to two nvidia GTX 780’s.

Yeah, I’ve tried with smooth frame rate on and off. And as far as gaming is concerned, I’ve never had any issues, or even in terms of 3D. I’ve had ATI since my first computer, and I can always force games to support Crossfire when they don’t. I think my guide on the forums is still better than the default support FFXIV A Realm Reborn has even after the crossfire patch. So I’m fine if for whatever reason crossfire doesn’t work natively, I can get around it presuming I can get proper full screen to work later down the line. But 112FPS in an empty void? On a single 7970, why?

Sorry if I’m being repetitive or just rambling, this is just super frustrating.

This is for any future people who come across this thread with performance issues. I had a huge performance drop across all of my maps in my project and then realized I was working was working from a laptop and didn’t have it plugged in.