Download

Paying 30 Dollars for Resolution

Paying 30 Dollars for Resolution

I will pay 30 Dollars to the first person I can confirm to fix our pipeline issue in regards to importing into the UDK Mocap Root Motions. I have been messing around with this for weeks now and this is becoming a big hold up someone please help us I am willing to pay for a solution. I am going to post this in Both UE4 Forums and Blender Forums. I can pay with PayPal or mail a cashier’s check, I am not joking I will pay to fix this issue.
Defining our pipeline

IPI Motion Capture – Capture Motions – Clean them best as possible and export them as BVH
BVHacker – Remove T-Stance – Zero Hips to have character facing Forward – Align character best you can to the deck
Blender 2.70 – We have our Rig Setup – Import BVH and Remap animations to a our skeleton.
Take that same blender file and in pose mode finalize the animation – Line it up to the deck – Add the up and down / turn or rotation of the character etc
Export FBX & Import into UE4

Lets say we have a crouch animation, I guess I am stripping away root motion and alignment etc in BVH so we can get the character facing the correct way and not moving all around the area but staying in place. So if I play the animation instead of the character dropping down to the deck his feet just raise up off the ground that’s fine in BVH. So once the animation is transferred in Blender I re-add that motion back in, IE go frame by frame and keep his feet firmly planted on the deck, All looks great in blender.

Not sure if that is root motion or not exactly or what to call it. I import it in and right now and by default the editor doesn’t recognize it as an animation, it thinks it’s a Skeletal Mesh and if I select animation it says that asset doesn’t appear to be that type and might not import correctly. Either way it imports and seems fine but this could be the issue as well not sure, this wasn’t happening before either. However that root motion I gave the animation back is gone, so feet are coming back off the deck again.

I thought perhaps its a root motion issue so I created an animation montage checking root motion but that’s doesn’t seem to fix the problem - just seems to change the origin point of the animation start not the location on every frame. I can also have root motion if I just animate in blender but then we are not using our motion capture information. So the issue is definitely happening in our pipeline. Believe it occurring when I zero out everything in BVH then import it to blender. I am someone unable to re-add root motion back in. I am not a top notch animator so having mocap means we have decent looking animations.

I want to say this wasn’t happening before about 5 months ago when I did all our character movement animations with the same workflow in which I wrote everything down on our wiki so I wouldn’t have to remember how to do this. Now I am doing all action animations and this is being a pretty big problem because most action animations have a lot of root motion movement in them. When you strip this and the hips never move, or turn over or go up and down just looks awful. I am thinking also maybe it has something to do with the Blender FBX exporter or UE4 Importer

And I am a novice animator so I am not trying to lay blame anywhere perhaps I am doing something wrong, I am looking for some understanding to the issue and guidance on how to resolve it.

I made a quick down and dirty Zip file of the exact issue I am outlining above, you can download the zip file below:

http://www.filedropper.com/rootmotionissue

Pray_01 = is the Raw output file from our motion capture and ready for BVHacker
Pray_02 = is the tweaking of the file of zeroing out the root bone
Pray_03 = is just after import and retargeting of the BVH file in blender
Pray_04 = is the adding of root motion back into the skeleton & the FBX of that

This has the exact issue of the feet coming up rather than the body staying on the deck and going down. It also has the issue of it not recognizing the animation. In blender the animation looks fine but in UE4 the player hovers rather than dropping to the deck. Anim montage doesn’t change this either.

Please Help it’s been weeks stuck on this issue with me testing and getting no where I will pay for help.

Thanks In Advance!

Okay Per Request Here are some videos going over almost everything.

Video #1http://youtu.be/MuYBUGDNpNY
Video #2http://youtu.be/OwRgEgvmeIw

Added some more files and vids

Here is the new video explaining the issue more clearly I think
http://youtu.be/8bLC7ckKRy0

Here are the files I used for the above vid
http://www.filedropper.com/examplematerials

Blender Thread

The downloadlink isnt working :slight_smile: (or I cant see anything on that site ^^) + a picture or a video of your problem would help us to solve your problem, because I think I probably had the same issue (but therefore I would need a video that shows the wrong anim) :wink:

Try clicking the download link again - it just worked for me - perhaps there site was having issues.

Yep, now it works :slight_smile:

-> that’s the part where a video would help to understand what exactly you mean, because root motion is here to move the character with the animation. e.g when you create a sword attack in which the mesh makes some steps forward it will return to the start position instead of staying where the anim stopped -> with root motion the mesh moves with the anim :smiley:

Okay Per Request Here are some videos going over almost everything.

Video #1http://youtu.be/MuYBUGDNpNY
Video #2http://youtu.be/OwRgEgvmeIw

I added them into the original post as well.

Ok, I had the same problem some months ago, but unfortunately I dont know how I fixed it ^^ But in my case it looks like that (I think correct):

https://youtube.com/watch?v=VH_Ff_JxKXI

-which blender version do you use?
-what are your export and import settings?
-I use version 2.7 with modified fbx exporter, because blender adds an extra root bone to the rigg http://krisredbeard.wordpress.com/tutorials/tutorial-blender-to-udk-player-model/

This is no fix as such, but in the interim why not export your animation from blender, somewhere else. You could try either art of illuision or anim8tor or even milkshape and lastly maybe maya LT trial (cant verify if saving is allowed in trial)

http://area.autodesk.com/products/features/mayalt

Clearly you can do everything in maya LT and easily export to unity &/or UE4, and the price tag is much cheaper than full maya . I make no assumptions about your fianaces, just offering alternatives given I’ve seen so many issues with blender so this may be your ‘fix’.

In the current vacuum of answers, can’t hurt to look into these options,though I suggest starting with mayaLT trial.

Cheers
nl

NeigbhborLee → No Not Helpful, thanks for your best effort though…

Fighter not at home right now but I know I use:

Blender 2.70
I have removed the root bone issue same way red beard outlines it – I will check again though to confirm
I will have to get back to you on the import / export setting I leave them pretty much default though.

So why don’t you tell me your export and import settings and I will mirror them when I get a chance.

Thanks Fighter looks like its working on your end, that’s a start for sure.

So, if you’ve worked on this for 2 weeks, and you want to pay someone to fix it, then you value someone else’s time at $15/week?

Or you get my help for $0/week :wink:


Here we go :slight_smile:

import_export.jpg

I dont know if this will help you, but here are my files so that you can test it out in your UE4: https://drive.google.com/file/d/0Bx4rUIObSdNYNnR2bTJ3c3A3cTQ/edit?usp=sharing

Jwatte, are you really this big of a douche? People are asking for help for free all over the place in here. I have been asking for help and not getting any response, thus I put up a month and a half cost of the UE4 to someone that can help me, So Jwatte **** off. At least its something which fighter I still intend to pay.

Now I can not download your files says too many people have accessed them or something wait 24 more hours and try again. However I don’t need to, somehow its started working and this makes no sense at all. The same files that offered up for download which I could re-produce the issue with are not re-producing the issue now. The only difference is the import setting of choose skeletal mesh and import animation checkbox. I always just say animation only and choose the skeleton but I tested it and that’s working too. So I think it might be a skeletal corruption? By re-importing everything I am re-doing the skeleton?I do not know this is not making any sense, I can literally not re-produce the video I posted with the exact same assets I posted it with.

Was there perhaps a UE4 Patch/Update that fixed this? I am seriously confused, the problem has just magically gone away and I can not contribute it to anything…

Ya this has got to be a skeleton issue, when I tell it to replace the original skeleton in our library it goes crazy with issues invalidating and says the bones have changed all the animation work we have done prior is not working. I dunno I am going to have to think about how I want to approach this but this is an issue.

A few choice swear words

Good to hear that it works now :slight_smile:

Acutally I also solved it some months ago without knowing how I did it (my team and I recreated the animations + exported it several times), but probably blender causes those strange issues from time to time XD

Ya this is the 3rd time some sort of physics asset or skeleton asset IE an asset that a bunch of other asset rely on has become corrupted. This is not occurring in blender its occurring in UE4. This is a big set back because its going to take me several days at least to delete all skeletons + animations and re-import them all back in and rename and re-line back up to coding etc.

Its the exact same skeleton we have been using the entire time - but the engine doesn’t want to recognize it. Why can’t we just edit the asset that is corrupt and force recognize everything that relies on it back to it. Nope soon as I do that all assets that rely on it become null.

This is just stupid and agrevating

Apparently you took it that way. It seems you’re quite frustrated, and I can relate to that feeling. I’ve been there many times myself.
Asking for free help is fine. Everybody does it all the time.
My point is that asking for paid help, but making the payment so far below market rate that it doesn’t matter, seems to me to be worse than asking for free help, because you’re sending the wrong signal about the value of the work.
People help out for free because it’s the right thing to do and “pays it forward.”
People help out for money to pay the bills, so if you want to pay someone to help, you have to play in that world, where $30 doesn’t even pay for the first hour of contracting.
You are of course free to disagree, but please tone down the personal attacks.

Hmm - I was asking for help and not getting any help.
I asked for help with a little added bonus and got my help.

Its a free market, the “value of the work” is determined upon the two between that make the agreement. If someone said they had my answer but 30 wont cut it then we can negotiate, but I don’t see anyone complaining about it but you & you don’t have my answer.

There are many people that have the UE4 Tools, from just messing around and learning/hobbyist to Indie to what I would be willing to bet it is a much smaller percentage commercial driven. I am not asking for someone to build an entire game for me or even a part of it. I have a bug, something that could be resolved in 5 minutes of looking at it or could take maybe 40 minutes. 30 bucks is 30 bucks, take it or leave it, if my money is no good to you then don’t take it.

If you don’t like what I am offering you can move on, in the title it says how much I am offering. If your trying to pay the bills then you see all you need to know in the title skip and look for a more permanent income stream oh wait I think there is a forum for looking for work, why not look there. I am not offering work and was offering a one time quick resolution.

To jump in my thread and say I am somehow insulting everyone because I didn’t say I wouldn’t pay 1 trillion dollars for something is absurd and trolling imho. So I treated a troll like a troll, Go back to your Cave!

Hey Fighter the problem isn’t actually resolved, I will have to make another video, Its not a straight forward as a skeleton corruption issue.

My rant was gonna be why can’t I more clearly edit physics assets and skeleton assets, especially when you can have so many assets dependent upon them. IE I have had several physics asset corruptions in which I had to delete a big batch of assets and then re-import them in. Wasting so much time when you do that, there has got to be a better way with dealing with them. Yes that whole re-map asset tool while deleting is awesome if it actually worked. I can not delete a skeleton and its physics asset and replace them, everything that is dependent upon them just corrupts.

I am going to re-test and re-confirm the problem and make another video.

I think I may have answered my own question for a solution during the video but not exactly. It seems the Root motion is only allowed and tied directly to the exact file the animation was created on. Its not skeleton or name specific its actually file specific. Which makes absolutely no sense to me, it might have something to do with the stride bone that gets added at creation of the mocap transfer, but there isn’t really a stride bone in the skeletal mesh.

My animations are broken up across a hundred files with various states of saves. I suppose I can try to figure out how to put all these animations on one blender file but that too me seems messy. Also why wouldn’t UE4 let it work, it obviously is playing the animation just not the root motion. I would rather have this managed differently, but I suppose if this is what its going to take to fix the problem I will try it. Please let there be a better solution though.

Here are the files I used for this video
http://www.filedropper.com/examplematerials

Here is the new video explaining the issue more clearly I think
http://youtu.be/8bLC7ckKRy0

Updating the first post to include them as well.

My next test will be to try and combine all the data into one blender file.

Okay so I am capable of combining all the animations in one file, its messy. Seems like the root motion issue is gone but now all the animations don’t line up to the deck and seem to start at different heights. In blender they are just fine. I am going to have to look into it more maybe its something simple that can be resolved but I would still prefer to have all my animations split up.

Again this seems silly that I can import animations for the skeleton and have them play but the root motion is gone.
Still to me seems like a UE4 FBX importer issue specifically with blender files.