Pathfinding fails to find solution on thin grid


I have a problem with getting navigation to work. On my game I have a grid of thin lines that the player can move on. On said lines, I placed a navigation mesh and configured agent radius accordingly.


On my AIController blueprint, I just call MoveToActor but it isn’t working unless I uncheck Use Pathfinding. Same problem occurs with other moving functions as well.

The function gets called and prints Failed.

What am I doing wrong? Where should I even begin looking?

I think I solved it. My pawn inherited from Pawn instead from DefaultPawn. Thus, it didn’t have a MovementComponent. When I re-parented my pawn, it worked.

– EDIT –

It seems that there was an underlying problem as well. My navmesh was messed up because I reconfigured agent radius on RecastNavMesh that spawned, instead of project settings. Problem solved when I changed settings.

CAREFUL! To modify Agent Radius you need to add another navigation agent. Don’t just modify default agent settings because it messes up everything.

Thank you, I had the same problem of having changed Agent Radius. Removing the nav bounds volume and the RecastNavMesh and creating a new nav bounds volume fixed it.