Download

Passing component location to material parameter bug?

Hello,

just wondering if anyone else has bumped into this problem, I am trying to feed a ‘Get Location’ (world location) of a Blueprint component into a material as a vector parameter.
But it just wont get passed in. I seem to be able to pass ‘Up Vector’ and some scalars fine. Also the location seem to be correctly passed when I by hand manipulate the top node ie the BP Actor level. Then the read of the component seem to ‘trigger’. But it does not trigger if I move the component itself.

Has anyone else seen this?

Cheers, Fredrik

maybe it depends on event when you pass the location.
try to do it in on construction, on begin play, and every tick and check difference

Yep I tried that but got the same problem.
I tried get WorldTransform and I tried adding a socket and asking its location but nothing.
If i pass a static value just entered into the BP node it gets passed so I know that the passing itself works.
Also I tried to do it via a variable.

How are you setup this? Do you create and use dynamic material instance?

Yep. And it works for other parameters and when I move the whole BP Actor.
Just not when I move the component on its own.