Download

passed own procID as game procID error when uploading to workshop

Hello,

I keep getting an error when trying to upload. The connection to Steam works fine (after running the SteamCMD.exe manually) and the mod listing shows up in the workshop - but during the process it gives an error. The error as shown in the stderr.txt log is “Assert( Assertion Failed: CClientGame::Init: passed own procID as game procID ):user.cpp:321” This happens after the line “Uploading preview image” displays in the Status window. Immediatly following that, on the same line after the … is “ERROR! Failed to update workshop item (Limit exceeded).” The next line in the status window is the error text above. The Status window reads:

Uploading preview image…ERROR! Failed to update workshop item (Limit exceeded).
Assert( Assertion Failed: CClientGame::Init: passed own procID as game procID ):user.cpp:321
Game update AppID 376040 “”, ProcID 0, IP 0.0.0.0:0
user.cpp (6170) : Assertion Failed: Calling GetUserConfigFolder before we know our SteamID
configstore.cpp (796) : Assertion Failed : false
some lines about CWorkThreadPool
shows where log is saved
0%] Checking for available updates…
----] Verifying installation…

Since the uploader still will not allow mods to be cooked and uploaded without being attached to a map, I first tried TheIsland (ambitious, I know, but I had to try.) Using DinoArena, or even TestMap still gives the same error sequence. I have changed the preview image to a 33kb png file to make sure it’s size isn’t over some limit.

I would appreciate any thoughts or assistance.

BlueFreakQ

Encountering exactly the same issue. Tried different set-ups but nothing.

Can you post the content of “DEV-KIT-PATH\ModTools\SteamCMD\logs\workshop_log.txt” , it should contain more info. about the file which passes the limit.

Hey ! got the same issue, here the content of my workshop_log.txt :

[2015-07-08 00:04:32] Uploaded new content ( ManifestID 1937276805330283997 ) for item 477269826.
[2015-07-08 00:04:33] Failed to write preview file F:\Program Files (x86)\Steam\steamapps\common\ARKDevKit\ModTools\Output\MyMod\CookedMods\MyMod\preview.jpg to remote storage (Limit exceeded) for AppID 376040

How large is this file “F:\Program Files (x86)\Steam\steamapps\common\ARKDevKit\ModTools\Output\MyMod\CookedMods\MyMod\preview.jpg”, the preview image?

Kinda sounds like the preview image is too large for steam workshop. They only allow file sizes so big and possible resolution limit but I forget exact limits off the top of my head. We should put a warning in editor if this is the case. Can you guys try a smaller preview image and see if it uploads?

I have reduced the image at around 15kb ( around 50px), can’t really do tinier than that

Are you uploading using the in-editor tool?
You are using 376040 which is the Appid of the devkit, you should use the game AppId which is 346110 in the vdf file, if you are uploading manually using steamcmd.

I’m using the in-editor tool yes,
and the .vdf file actually have this line : “appid” “346110”
so I don’t really understand why it go to 376040

Can you try launching the DevKit editor directly from \steamapps\common\ARKDevKit\ARKDevKit.bat and let me know if it works for you?

That what I usually do, and yes it works

I meant if the uploading works when the editor is not launched from steam? if still not working please try closing the Steam client before trying.

I don’t know if it because i have deleted the .vdf file, or started the editor from the .bat, but the uploader finally worked.

Will be home in a couple of hours and will give it a try. The image I tried to upload was a horrible 7kb image and still it would fail… but yes will try the external uploaded and will let you know.

Ok confirmed… worked if called outside of steam.

We are working on a fix and will update the dev kit ASAP.

Thank you, it is much appreciated. I have been able to successfully upload a mod using the information here and elsewhere on these boards.

Yeah for now it’s tricky and we’ve e-mailed Valve about the issue, we can’t seem to upload from one AppID (the devkit) to another AppID (the game). The solution for the time being is to run the DevKit directly, not thru the Steam Client, by manually running the bat file here:

[Your Steam Library Path]\steamapps\common\ARKDevKit\ARKDevKit.bat

Cheers,
Drake

I try now to update my Map for 9 hours, but no matter what I try, it won´t work…
How can I update it manually?

Is there any option to upload the map anywhere else then steam?

You can try using my launcher to do the upload if you haven’t already, it automates using SteamCMD to do it directly. You can get it from here: