Particles that movign with Weapon? (Muzzle Flash)

Hi there,

i searched the whole Internet, but can’t find anything. So i hope someone could help me.

I maked some Weapons and followd some tutorials (i’ve just learning). I created some Muzzleflashes and the weapon can shoot. But, if i shoot and run, the muzzleflash (out of particles) don’t move
with the weapon. Meaning: The muzzle appears, but stay on his Location at Shooting.

I have all done in Blueprint and set the particlesystem with “spawn particle attached”. When i’m Shooting the particles are spawned with “spawn particles Location”. I’ve tryed everthing but i can’t get it to work, that the particles move with my weapon. It should be like the Shooting demo from the marketplace.

The tutorial i follow was this: Shooter Game Tutorial: Content

What am i doing wrong? Sorry for no blueprints, but actually im at work. I hope you understand what i mean (my english is very bad :o(


Since the particle effect is already attached to the weapon, you’ll want to open up the particle effect editor and find the “Use local space” option in the “Required” module for the muzzle flash emitter:


This option makes particles move with whatever they’re attached to, instead of moving independently once they’ve spawned. Hope that works for you :slight_smile:

Thanks for the quick answer, but: At all Emitters the use local space is enabled allready.
Hm…thats all weird.

I have a look when i’m home and post some Screenshots. But thanks for the answer.

When you’re using the Spawn emitter at location node are you using the the get actor location for the emitter location and get actor rotation for the rotation?

This should get you the results you want with having the emitter to spawn with you. If you look at the First Person Template and how the projectile is spawned you can get some offsets there.

If you’re still having issues be sure to post some screenshots of your blueprint to make it easier to diagnose and give you some feedback. :slight_smile:


Hi Tim,

im not sure if i made it right. Here are the Blueprints.

The effect spawns at the right place, but dont move with me. Or did i something forgot?
Here is a Video to Show, how it Looks like:

EDIT say:
Does anyone know how to fix this?

I think i fixed the Problem. I have to use “Spawn Emitter attached”, not “Spawn Emitter at Location”. I should really read the Infos at the Pop up box :o

So Spawn Emitter at Location only spawns the Emitter on my last Location where i hit fire. But of course it will stay at the Location. So it’s my bad.