Particles stopped working in 4.11


So I’d really like to use 4.11 for the capsule shadows, but when I run my game in 4.11 some of my particles stop working .
I had hopes that the hotfixes would sort it out, but sadly it is still broken in 4.11.2.

Maybe somebody else has the same problem and there’s a way to fix it, or I wait for the next hotfix and epic see this and fix it.

Thanx Garth


Can some one with 4.11.2 please do me a solid and open the 3rd person project and add the fire from the starter content and check if it works correctly, I need to know if I’m the only idiot with this problem.


Hey fallenHere,

You mention capsule shadows, but do not see how that pertains to the issue at hand. Could you provide me with some simple screenshots so I can get an idea of what you are seeing?

I just tested the Third Person Example map using the P_Fire and had no trouble getting it to animate and run as expected. Perhaps you have not enabled ‘Realtime’ within the viewport which is why your particles seem to freeze?

Thank you,

Hi Mr.

Thanks for replying I was giving up on getting answers!

I only mentioned Capsule shadows cause I’d like to use them in my project,
but I can not because of the particle problem in 4.11. I’ll stick with 4.10.4, Its how I came up with the name for my project “Ten4”.

The first pic is a standard 3rd person project (only changes I’ve made is adding the two particles). To the left of the character is P_Sparks which works great,
but to right is P_Fire which does not work correctly.

The second Pic is to show that it is the P_Fire particle. In Construction Mode

The 3rd Pic is of my project using a modified P_Fire for foot rocket (boosters),
which completely disappears (Don’t work) when moving to 4.11.2

The last pic is to show how much better characters look with shadows.

Mr while I’ve got your attention another big problem I have is “AIPerception Peripheral Vision Angle Degrees” I need to change this value at run time in BP’s, I’m still struggling to get Visual Studios to work with UE4 so I can make My own node to change this value, but what worries me is I don’t know if this value can be change at run time using C++, maybe I’m wasting my time with visual studios. Could you please see what you can find out about this. I’d be very very grateful. ( I’d really like this to be a BP only project)

Other than this my project is going very well and I love UE4.

Thanks to all who made it possibly for me to be making this awesome Game!

Thanks Again from

GARTH (fallenHere)

Let me start by saying, we really appreciate your dedication to Unreal and your faith in our community :slight_smile:

Your game looks pretty cool and you should definitely share the finished product with us on the Forums in the Released Projects section for some feedback. On to your issues!

The first thing I would make sure, is that your ‘Engine Scalability Settings’ are set to Epic so you are seeing the highest quality for ‘Effects’ which are your particle effects. Hopefully that resolves your issue for the particle effects, but let me know if you still need some assistance.

For tracking purposes, and since your questions is a bit out of my own range of current knowledge, we ask that you create a new AnswerHub post for the AI perception question. I would make sure to add you are experiencing issues with getting Visual Studio to work correctly. You will want to use Visual Studio 2015 as we are moving towards that compatibility.

Thank you,

Hi Andrew

Sorry that’s not the problem, always had everything set to “epic”.
I then tried all the render setting still not working.
I’m getting the same problem on my desktop machine (Nvidia) and my Laptop (AMD). So don’t think it’s video drivers or anything related to the PC.
I’ll stick with 10.4 for now.

If anything comes up regarding this problem please send me a message.


Ok, well if you are able to narrow down the cause of the issue on your end I would be glad to continue to assist you.

Hi Andrew

I fixed it!
I was wondering how come you could place P_Fire and it worked, I then realized the default 3rd person project I used, was also moved from 4.10.4 to 4.11.2, I then made a new default 3rd person project in 4.11.2 and added P_Fire and P_Fire worked correctly. ( do you mind testing this for me if you have 4.10.4 and 4.11.2 installed, I’d like to see what the result would be ).

I then redid my project in 4.11.2 well most of it there is a lot to do, I then tested the footJet particles and nothing failed. Then tested the default P_Fire in my project it worked great, cause my particle was made from P_Fire I remade it in 4.11.2 and it’s working.

Another big favor please, my question re. “AIPerception Peripheral Vision Angle Degrees” I did as you asked and made a new post, but I’m getting no reply’s will you please message somebody who might know and ask them to check my post “Can AIPerception Peripheral Vision Angle Degrees be changed at Run Time using C++”.
I really really need an answer to this question before I install C++.

Thanks for your time and effort.


Glad you figured out the issue.

I found your issue and assigned it to some of our C++ technicians who will take a look and assist you. I will say, it is always worth installing Visual Studio to be able to open your blueprints in code in case you want to debug or modify lines as you are describing.


Hi Andrew

I posted a video of my game on the work in progress forum but nobody is commenting, could you please go watch the video and tell 1. is the video good enough 2. what you think of the game