Particles don't show in Orthographic camera mode

Hi guys what can i do to showing particles in Orthographic camera mode? for example in perspective mode i see particles in viewer and when i change camera my particles disappear

some how i fix this problem on my particles, but standard “fire”, disappear in Orthographic camera mode

Can you guys use the preview of the orthographic camera at all? Here it shows just the silhouette, although in game it works correctly. Even on Flappy Bird I get this behavior.

Hi everyone,

AFAIK the particle system shoul

d be visible (though probably difficult to see) in the orthographic viewports. I just attempted this with success:

What version of the editor are you using?

I find I’m having the same issue using particles from UE4.3 sample project. Playing the game in orthographic shows no particles, however when I eject they appear fine. I am using the “Flame” particles, and the only particles appearing on the screen in Ortho are the spark particles.

Hi mmillwood,

Can you post screenshots of what you are seeing? I am having trouble reproducing this on my end and any clarification would help significantly.

i create video with a problem Unreal Engine 4 Particles don't show in Orthographic camera mode - YouTube

PS in video you can see jetpack particles show in all camera mods but first jetpack particles has same problem but i change something(don’t know what i change(((( ) in Cascade and this fix problem

Hi Adam, I’m seeing exactly what zip is showing in his video - fire particles show when detached and only spark particles in ortho (no flames or smoke). I have noticed, however, that deploying the game to device (Galaxy SIII) shows the particles correctly in orthographic mode. Seems to only be an issue with the editor (afaik).

Hi everyone,

With the additional information I was able to reproduce this and have entered a bug report for this to be assessed. Thank you and have a great day!

Hi, I’ve been keeping my eye on this thread and was wondering if there had been any updates or a time frame for fixing this?

Does anyone have a temporary workaround? I can’t see how anyone is making any 2d games that have particle effects with this issue.

I have the issue when playing the game. All cameras are fine except for when I switch to an orthographic camera where half my particles stop rendering (the particle effects which are ‘firing’).

Hi Balka,

This is still under assessment by the development staff. Unfortunately, I do not have an adequate timeframe to give you on when this will be fixed.

is this already fixed? any ETA?

Hi Dredok,

Unfortunately this has not been fixed as of yet, it is still being assessed by the development staff.

As a temporary fix following worked for me: open sprite material (eg fire, smoke or whatever) and change the DepthFade-value to zero. Unfortunately it’s not a proper solution, but in my case it’s better than nothing. Hope it helps.

(I added a param for DepthFade-value, so I am able to change it on the fly, depending on my camera mode).

Hi paragonx9,

Unfortunately I do not have a timeframe of when this will be fixed. Keep an eye out for our release notes on future updates!

Any insight? :smiley:

It’s 4.8.0-preview3 and still not fixed!

Hi cailei,

Unfortunately this has not been fixed as of yet. Our resources are currently allocated elsewhere. I have updated the bug report to reflect that additional developers are experiencing this error.

Awesome, this did it for me! Been scratching my head about this one for weeks, remade my sprites several times and a slew of other things trying to figure it out. Thanks a ton.