Particles don't render properly with orthographic camera

Hi, I’m not sure if this is supposed to happen, but my particle effects render really weirdly when I’m using an orthographic camera.

Here’s what they look like in perspective:

Here’s what they look like in orthographic:

As you can see, it’s missing much of the detail. If it weren’t for the lack of sharpness and the blurriness I get when I use a perspective camera, I wouldn’t mind using it. So if anyone knows how to make a perspective camera look and feel like an orthographic one, then that would work X’D


Hey paragonx9 -

From just the images you have posted this looks like you are having an orientation issue with the sprites in the particle system. This can happen in Orthogonal when you are using the Velocity aligned sprites. Try to use a camera facing, square or rectangle screen alignment if you can.

If that happens to not be the problem, post a screenshot of your Cascade setup, so I can try to duplicate what you have to test further.

Thank You

Eric Ketchum

Thanks for your reply :slight_smile: What do you mean by “camera facing, square, rectangle screen alignment”?

In Cascade in your emitter’s Required Module, you have a screen Alignment setting which by default is set to PSA_Square.

Although it did make the particles that already render look better, the ones that were absent still are.


Anyone? I’m still facing this issue… I can’t use a perspective camera for my game :confused:

Hey Paragonx9 -

Have you tried adding an Orientation > Lock Axis > Y module to each of your emitters so the sprtie is locked to the flat Y axis like your other sprites?

Thank You

Eric Ketchum