Particles Don't Have Collusion

As you can see, although there’s a collusion module, my particles are still flowing through walls, meshes. How can i solve that?

Yours Sincerely,

Mustafa Berke Güreltöl…

In which title is it?

You need to enable scenedepth in your project settings.